[mythtv-users] audio gone with pvr-350?

Matt Price matt.price at utoronto.ca
Mon Mar 5 17:15:53 UTC 2007

On Mon, 2007-03-05 at 01:53 -0500, f-myth-users at media.mit.edu wrote:
> > Date: Sun, 04 Mar 2007 22:56:30 -0500
>     > From: Matt Price <matt.price at utoronto.ca>
>     > hey again,
>     > in my last post i described some problems i'm having upgrading a mythtv
>     > system to 0.20 from 0.18.  fortunately (i thought) i had carefully
>     > cloned my underlying system before upgrading.  so i have my old 0.18
>     > system back up and running, and everything's fine=20
>     > ... except...
>     > now all of a sudden my pvr-350 no longer RECORDS audio.  the old
>     > recordings, from 2 or 4 days ago, still play back normally with audio as
>     > expected, but the new recordings, have perfect video but play no audio
>     > at all.  as far as i can tell the audio stream is simply missing from
>     > the file.
>     > i'm getting some ivtv0 messages in dmesg, don't know if this has
>     > anything to do with it, but here they are:
>     > [4295346.638000] ivtv0 warning: i2c client addr: 0x40 not found for
>     > command 0x80287610!
>     > [4295346.638000] ivtv0 warning: i2c client addr: 0x40 not found for
>     > command 0x40287611!
>     > so it would be great if anyone could help with this.  i look forward to=20
>     > getting SOME version of mythtv back up and running!
> In your .20 system, did you happen to change the -ivtv- release
> version while you were testing?
> If so, it may have loaded different firmware, and, if so, a cold-boot
> that doesn't also include 30+ seconds of absolutely no power might be
> using registers that were set for the newer ivtv release and which
> don't work right with the older ivtv release.  So that might be a
> quick test to try:  shutdown, unplug the power and network (!) cables,
> wait 60 seconds, reverse & reboot.

that sounded like a good idea, but i tried it -- no go. even tried
unplugging everything for 10 minutes, still didn't work.  any place i
can find out mroe about which registers ought to be used in which ways?
> Failing that---did you perhaps open up the case at all?  Rearrange any
> cables?  Maybe you need to reset the 350 in the PCI bus or something.
> Or, if you're feeding composite to the 350, could you perhaps have
> disconnected an audio plug? :)  Stupider things have happened to us
> all...
agian, not it -- didn't open up the case, and the input is a standard
coaxial cable -- it's on rock-solid, but even if it weren't i'd be
expecting to get static at least...

> (The way -I've- set up test machines is by actually cloning the entire
> partition with dd [while in single-user mode, so nothing's modifying
> files], which means that I'm not trusting rsync to get device nodes
> correct or things like that.  That requires a little thinking ahead
> with either repartitioning or using LVM, but has seemed pretty
> reliable so far---but requires -extreme- care to make sure you -never-
> reverse the "if" and "of" arguments to dd! :)

should have done that perhaps, though i used rsync from a livecd, so
none of the stuff in /dev/ proc/ and so on were replicated.

anyhow, thanks, nay more ideas?


Matt Price
History Dept
University of Toronto
matt.price at utoronto.ca
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20070305/694494aa/attachment.pgp 

More information about the mythtv-users mailing list