[mythtv-users] errors and puzzles about the steps of compiling MythTV SNV on Fedora

Xi Jiarong XiJiarong at sp.edu.sg
Mon Mar 5 13:40:05 UTC 2007

I want to develop some plugin on mythtv, but I tried to install mythtv from
svn and comile source code, but never succeed, so dispointed.
Therefore, I have to ask for your help.
The following steps are adopted by me.
If there are some errors or some need to be correct, please give me some

1. Install MythTV according to the guide: Installing MythTV on Fedora Core
on web :
http://www.mythtv.org/wiki/index.php/Installing_MythTV_on_Fedora_Core   or
there are some little different from each other.
after then, I can use mythtv via terminal

2. Uninstall and remove MythTV package from the current system through the
following commond on terminal:
 # rpm -qa | grep myth | xargs rpm -e
(QUESTION 1: Is this way right? or use #yum remove myth*;  and #yum remove
libmyth*??? )

3. Install depencies through:

   yum install gcc-c++ freetype-devel lame-devel qt-devel mysql-devel
lirc-lib-devel subversion mesa-libGLU-devel libXv-devel libXxf86vm-devel
libXmu-devel qt-MySQL
              libXvMC-devel kdelibs-devel
  and others......
(QUESTION 2: How to judge whether all those dependencies required for
compiling had been installed successfully??? )

4. Create the corresponding folder and download the source code, throuth
the following way:
   $ mkdir mythtv_build
 $ svn co http://svn.mythtv.org/svn/trunk mythtv_build
(QUESTION 3: I ran #svn update after finishing the above command, Did this
have any problems ?)

5. Compiling and make process: run the following command respectively:
(QUESTION 4: Are there any problems for the following run command??)
   # ./configure --prefix=/usr/local
   # qmake PREFIX=/usr/local mythtv.pro
   # make
   # make install
but, I still can not compile successfully.  The foloowing output is from
the terminal:
 (QUESTION 5: How to resolve this problem??)

[root at localhost mythtv]# ./configure --prefix=/usr/local
# Basic Settings
Compile type     release
Compiler cache   no
DistCC           no
Install prefix   /usr/local
CPU              x86_32 (i686)
big-endian       no
MMX enabled      yes

# Input Support
Joystick menu    yes
lirc support     no
Apple Remote     no
Video4Linux sup. yes
ivtv support     yes
FireWire support no
DVB support      no [/usr/include]
DBox2 support    yes
HDHomeRun sup.   yes
IPTV support     yes

# Video Output Support
x11 support      yes
xrandr support   yes
xv support       yes
XvMC support     no
XvMC VLD support no
XvMC pro support no
XvMC OpenGL sup. no
Mac acceleration no
OpenGL vsync     no
DirectFB         no

# Misc Features
Frontend         yes
Backend          yes

# Bindings
bindings_perl    yes
Creating libs/libmyth/mythconfig.h and libs/libmyth/mythconfig.mak

[root at localhost mythtv]#make
/usr/local/lib/libmythtv-0.20.so: undefined reference to
/usr/local/lib/libmythtv-0.20.so: undefined reference to
collect2: ld returned 1 exit status
make[2]: *** [mythtv] Error 1
make[2]: Leaving directory `/home/mythtv/trunk/mythtv/programs/mythtv'
make[1]: *** [sub-mythtv] Error 2
make[1]: Leaving directory `/home/mythtv/trunk/mythtv/programs'
make: *** [sub-programs] Error 2

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070305/3a1c7e66/attachment.htm 

More information about the mythtv-users mailing list