[mythtv-users] fiberoptic IPTV recording on mythtv

Nate Crosno nate at crosno.net
Sun Jan 21 20:09:19 UTC 2007

Pedro Pessoa wrote:
> Hi Nate,
> Sorry for this late answer, I've been trying to come to a final setup on my box. Read on.
> One thing I learned from Mike Mironov is that I had to abandon my previous setup of .20 from the released tar ball with Mike's patch.
> You need to go to the latest SVN. It works out of the box. Just follow the mythtv/libs/libmythtv/iptv/README.UDP.

I have not tried the SVN yet.  WAF, was very, very low and is just 
starting to bounce back. I don't want to cause any down-time, so I'm a 
little hesitant at the moment.  I do have an older machine that I am 
thinking about temporarily using to test the SVN version though.

>> Right now, I have two problems:
>> 1) I can view and save the stream using VLC or Xine, but I do not get
>> any sound.  I copied the test file to a windows box and did get sound
>> when watching VLC.  I have tried to compare the file with known good
>> files saved off my HD DVB card and cannot tell the difference -- both
>> have A/52 set as the audio codec and MPEGTS for video.
> So a mpg file saved with Xine on Linux from the multicast stream plays video and audio on a windows box, but the audio is not played on Linux? Is this what's going on?

Yes, if I save it from VLC, it will play video and audio in VLC on 
windows, but only video with VLC or Xine on Linux (gentoo).  I did just 
find out that it will play both audio and video with mplayer on the 
mythtv box, but the audio is way off sync.  I tried to post about this 
extra info, but my emails do not seem to be making it through to the list.

>> 2) I have tried several variations of URLs in the Mythtv setup, and myth
>> tries to record something, but I always end up with an empty file.
>> Here is some info about my setup -- Gentoo on Mythtv ebuild 0.20_p11626.
>> I currently have the URL set as this:
>> udp://  I also tried without "multicast=1".
>> I don't seem to be getting any errors in the log.  I have two network
>> interfaces on the box -- wlan0 connects to the internet and I took the
>> ethernet cable from the Amino STB, put it into a hub, then one line to
>> the STB and one to the myth box on eth0.  I had to add some routes so
>> the multicast addresses would listen on eth0.  When I do a tcpdump, I
>> get this:
>> #tcpdump -i eth0 -c 10 udp
>> tcpdump: verbose output suppressed, use -v or -vv for full protocol
>> decode
>> listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
>> 08:18:30.139731 IP > UDP, length 1316
>> 08:18:30.142180 IP > UDP, length 1316
>> 08:18:30.145209 IP > UDP, length 1316
> So you start VLC and can play the video stream, then you stop VLC and start mythbackend on the same box and cannot get anything?

Correct.  I tried feeding the saved stream through mencoder (to dvd 
specs, just for a test) and mythtv would then play both video and audio! 
  The audio was still out of sync.

> Let me know if you get the same results when you try with the latest SVN.
> BTW, you need a webserver to put your m3u file. I couldn't serve it from the webserver I have on my mythtv box. I had to use another box. This box is online, email me if you need some help here.

Thanks.  Web stuff is my day job, so that won't be a problem.  However, 
I'm still very reluctant to upgrade until I know I'll be able to play 
the stream natively in myth without having to re-encode.  There are lots 
of times my wife wants to watch shows before a transcode job has had the 
chance to run....(which incidentally has been a great annoyance to her 
for high def channels, since xvmc is not working for me and our PCI 
video card does not have the bandwidth to let the P4 do it's job. The HD 
channels are coming OTA from an ATI HD Wonder).

I'll probably try the SVN on a test box.

Thanks again,

More information about the mythtv-users mailing list