[mythtv-users] fiberoptic IPTV recording on mythtv

Pedro Pessoa prp at pobox.com
Sun Jan 21 13:33:07 UTC 2007

Hi Nate,

Sorry for this late answer, I've been trying to come to a final setup on my box. Read on.

On Monday 08 January 2007 16:36, Nate Crosno wrote:
> > From: mythtv-users-bounces at mythtv.org
> [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Pedro Pessoa
> > Sent: Sunday, January 07, 2007 7:27 AM
> > To: mythtv-users at mythtv.org
> > Subject: Re: [mythtv-users] fiberoptic IPTV recording on mythtv
> > 
> > This update is very interesting. Let me describe my current setup:
> > - mythtv compiled from mythtv-0.20.tar.bz2 (after the 'a' patch
> relase) on a 
> > Mandriva 2007 machine.
> > - patched with crcipnetworkchannel from Mironov M.S. 
> > http://www.gossamer-threads.com/lists/mythtv/dev/216104
> > 
> > I just needed to setup a MPEG-TS recorder "capture card"
> > http://www.gossamer-threads.com/lists/mythtv/dev/202882
> > 
> > then using Mironov's patch I'm able to setup all the channels I have
> using 
> > their multicast address. The "tuner" will then work and act like any
> other 
> > video source. It's great.
> > What will the new developements on the mythtv-iptv branch bring? Is
> there any 
> > description somewhere? I'm wondering how painfull, or painless it will
> be for 
> > me to update my setup to the new code.
> > 
> > However, I have one problem. Some of my multicast channels cannot be
> displayed 
> > on live tv! I can record them like any other, and them watch the
> recording, 
> > but when it comes to live tv, they just don't play. And I'm a bit at a
> loss 
> > to know where to look for any error... help is welcomed.
> > 
> > Regards,
> > Pedro Pessoa
> I'd be very interested to learn more of your setup....specifically, what
> is in your capturecards table and possibly any hiccups you ran into
> during setup.

One thing I learned from Mike Mironov is that I had to abandon my previous setup of .20 from the released tar ball with Mike's patch.
You need to go to the latest SVN. It works out of the box. Just follow the mythtv/libs/libmythtv/iptv/README.UDP.
> Right now, I have two problems:
> 1) I can view and save the stream using VLC or Xine, but I do not get
> any sound.  I copied the test file to a windows box and did get sound
> when watching VLC.  I have tried to compare the file with known good
> files saved off my HD DVB card and cannot tell the difference -- both
> have A/52 set as the audio codec and MPEGTS for video.

So a mpg file saved with Xine on Linux from the multicast stream plays video and audio on a windows box, but the audio is not played on Linux? Is this what's going on?
> 2) I have tried several variations of URLs in the Mythtv setup, and myth
> tries to record something, but I always end up with an empty file.
> Here is some info about my setup -- Gentoo on Mythtv ebuild 0.20_p11626.
> I currently have the URL set as this:
> udp://  I also tried without "multicast=1".
> I don't seem to be getting any errors in the log.  I have two network
> interfaces on the box -- wlan0 connects to the internet and I took the
> ethernet cable from the Amino STB, put it into a hub, then one line to
> the STB and one to the myth box on eth0.  I had to add some routes so
> the multicast addresses would listen on eth0.  When I do a tcpdump, I
> get this:
> #tcpdump -i eth0 -c 10 udp
> tcpdump: verbose output suppressed, use -v or -vv for full protocol
> decode
> listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
> 08:18:30.139731 IP > UDP, length 1316
> 08:18:30.142180 IP > UDP, length 1316
> 08:18:30.145209 IP > UDP, length 1316
> 08:18:30.150283 IP > UDP, length 1316
> 08:18:30.153330 IP > UDP, length 1316
> 08:18:30.155433 IP > UDP, length 1316
> 08:18:30.158480 IP > UDP, length 1316
> 08:18:30.158532 IP > UDP, length 128
> 08:18:30.161367 IP > UDP, length 1316
> 08:18:30.163422 IP > UDP, length 1316

So you start VLC and can play the video stream, then you stop VLC and start mythbackend on the same box and cannot get anything?
Let me know if you get the same results when you try with the latest SVN.
BTW, you need a webserver to put your m3u file. I couldn't serve it from the webserver I have on my mythtv box. I had to use another box. This box is online, email me if you need some help here.

Good luck,
Pedro Pessoa

More information about the mythtv-users mailing list