[mythtv-users] MythWeb question

Chris Petersen lists at forevermore.net
Fri Jan 19 05:22:24 UTC 2007

Matt Hannan wrote:
> mythtv-0.20-149.fc5.at
> mythtv-backend-0.20-149.fc5.at
> mythweb-0.20-149.fc5.at
> mod_perl-2.0.2-5.1
> https://www.nycnyne.net/mythweb/pl/stream/1056/1169174828
> As for
> "and verify that you have the apache conf (svn) or .htaccess file (.20)
> configured properly to deal with perl"
> I do not know what you are looking for.
> I found
> LoadModule perl_module modules/mod_perl.so
> in my httpd.conf.

I hope that you haven't somehow enabled mod_perl for mythweb -- it needs
perl to be running in cgi mode, not as a module.

> And I do not use .htaccess to lock down my mythweb.

The .htaccess file for mythweb doesn't do auth, but it does set up
everything else that you need to have in order for mythweb to work properly.

I still need to know if you have modified your .htaccess file, or if
it's not the standard file that comes with MythWeb (properly configured,
it should circumvent any mod_perl config, and set up everything that is
needed for MythWeb to run properly).  The only thing I can think of is
if perhaps the .htaccess file you have is left around from an earlier
version of MythWeb, and the package didn't update the file.   Have you
tried removing/reinstalling the package?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20070118/0a016dc5/attachment.pgp 

More information about the mythtv-users mailing list