[mythtv-users] moving database from FC4 to gentoo (mysql 4 to 5)

Brad Fuller bradallenfuller at yahoo.com
Sun Feb 11 21:04:12 UTC 2007

I'm looking thru the online MySql docs but can't find the answer. The 
mythtv gossamer threads server seems to be down (Unable to connect to 
search server: Connection refused)

I'm trying to move a mythtv database from FC4 to Gentoo

On the FC4 machine running mysql version 4 I dumped the mythconverg 
database using:
mysql dump -tc -u mythtv -p mythconverg > mythdb.sql

On the gentoo machine (it's actually the same machine) I ran the
mysql -u root -p < /usr/share/mythtv/database/mc.sql

because I figured I needed to add the user first.

I DROP'd the database and I tried to restore the database using from the 
FC4 database:

mythsql -u mythtv -p mythconverg < mythdb.sql

but I receive the following error:

ERROR 1146 (42S02) at line 21: Table 'mythconverg.callsignnetworkmap' 
doesn't exist.

Note that gentoo is running MySql 5. But, I don't know if this is the 
problem, or not.
callsignnetworkmap is the first table in the mythdb.sql file. So, I 
don't think that it doesn't exist.

Any hints?


More information about the mythtv-users mailing list