[mythtv-users] moving database from FC4 to gentoo (mysql 4 to 5)

David Campbell dave at cpfc.org
Sun Feb 11 21:23:03 UTC 2007

Brad Fuller wrote:
> I'm looking thru the online MySql docs but can't find the answer. The 
> mythtv gossamer threads server seems to be down (Unable to connect to 
> search server: Connection refused)
> I'm trying to move a mythtv database from FC4 to Gentoo
> On the FC4 machine running mysql version 4 I dumped the mythconverg 
> database using:
> mysql dump -tc -u mythtv -p mythconverg > mythdb.sql
> On the gentoo machine (it's actually the same machine) I ran the
> mysql -u root -p < /usr/share/mythtv/database/mc.sql
> because I figured I needed to add the user first.
> I DROP'd the database and I tried to restore the database using from the 
> FC4 database:
> mythsql -u mythtv -p mythconverg < mythdb.sql
> but I receive the following error:
> ERROR 1146 (42S02) at line 21: Table 'mythconverg.callsignnetworkmap' 
> doesn't exist.

1. delete the database on gentoo

mysql -uroot -p

mysql> drop database mythconverg;

Then recreate it;

mysql> create database mythconverg;

2. Dump the myth db on the fc server

mysqldump --opt -uroot -p mythconverg > mythconverg.sql

3. import the database on the gentoo server

mysql -uroot -p mythconverg < mythconverg.sql

David Campbell :: www.cpfc.org

More information about the mythtv-users mailing list