[mythtv-users] Lament: mythstreamtv

McNally mcnallychris at pobox.com
Fri Feb 9 21:07:30 UTC 2007

Following the wiki I got MythStreamTV to work in Myth 0.20 except for 
the sound :-(

The error reported on the Mythweb page is

 Starting Stream of /myth/2023_20070206200000.mpg
VLC media player 0.8.4a Janus
[00000270] main interface: creating httpd
[00000275] stream_out_transcode private error: cannot find encoder
[00000275] stream_out_transcode private error: cannot create audio chain
[00000286] main packetizer error: cannot create packetizer output (mpga)

No audio option fixes it, neither mp3 or A52. I think this is due to my 
ffmpeg version. I've tried to compile ffmpeg as described in the wiki 
but I get errors on the make. I tried the latest SVN of ffmeg as well. 
Compile problems even after installing the dependencies. I think VLC is 
a great product and I would like to get this working somehow. Seems my 
only option is to install Knoppmyth, which comes with a working Mythweb 
and Mythstream TV. I spent a good amount of time perfecting my Myth 
install so I would like to keep it.

my current versions of ffmpeg and video lan

# rpm -qa | grep ffmpeg

# rpm -qa | grep videolan

I am using Fedora core 4. If someone on the list has this working, is it 
possible to share your sucesss with me?  I would prefer to have
 an RPM, but any other assistance would be appreciated.

Here is the original compile error of the recommended ffmpeg

[root at localhost ffmpeg-0.4.9-pre1]# make
make -C libavcodec all
make[1]: Entering directory 
gcc -O3 -g -Wall  -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 
-D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o common.o common.c
In file included from avcodec.h:14,
                 from common.c:28:
common.h:67: error: array type has incomplete element type
common.h:71: error: array type has incomplete element type
make[1]: *** [common.o] Error 1
make[1]: Leaving directory 
make: *** [lib] Error 2

More information about the mythtv-users mailing list