[mythtv-users] mythtv-setup and X forward

Steve Peters - Priority Electronics steve at priorityelectronics.com
Thu Aug 30 01:42:35 UTC 2007

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Joe Ripley
Sent: Friday, August 24, 2007 8:00 AM
To: Discussion about mythtv
Subject: Re: [mythtv-users] mythtv-setup and X forward

On 8/24/07, Joacim J <jocke4news at gmail.com> wrote:
> I have tried running it over VNC but get:
> ======================================
> root at frodo:/home/joacim# /usr/local/mythtv_svn_r14230/bin/mythtv-setup
> Xlib: connection to ":1.0" refused by server
> Xlib: No protocol specified
> mythtv-setup: cannot connect to X server : 1.0 
> ======================================
> How can I run this?

How are you attempting to use VNC?  There are basically two ways to get VNC
access to your desktop.  One is to run the Xvnc server and one is to use the
the VNC module for X.  Perhaps you should take a look at


> Is it possible/better to start mythtv-setup from a regular SSH session 
> and in that case how?

You can tunnel X apps over SSH quite easily.  Just use a command like:  ssh
-X <hostname>

And then run your X apps. If you need more info, try this:

Joe Ripley
vitaminjoe at gmail.com _______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org

Hello, I tried to do "ssh -X <hostname>"
I typed in a command to run and it showed up on the screen of the computer I
was logged into, and not on my screen. Any ideas? (btw, x was running on
that computer, not sure if that makes a difference)


More information about the mythtv-users mailing list