[mythtv-users] mythtv-setup and X forward

Joacim J jocke4news at gmail.com
Fri Aug 24 15:42:38 UTC 2007

On 8/24/07, Joe Ripley <vitaminjoe at gmail.com> wrote:
> On 8/24/07, Joacim J <jocke4news at gmail.com> wrote:
> > I have tried running it over VNC but get:
> >
> > ======================================
> > root at frodo:/home/joacim#
> > /usr/local/mythtv_svn_r14230/bin/mythtv-setup
> > Xlib: connection to ":1.0" refused by server
> > Xlib: No protocol specified
> >
> > mythtv-setup: cannot connect to X server : 1.0
> > ======================================
> >
> > How can I run this?
> How are you attempting to use VNC?  There are basically two ways to
> get VNC access to your desktop.  One is to run the Xvnc server and one
> is to use the the VNC module for X.  Perhaps you should take a look at
> this:
> http://ubuntuforums.org/showthread.php?t=259448

Yes, that's exactly the guide I have used to set it up. I have also tried
x11vnc with similar problem.
Using that guide (Xvnc) on another machine didn't managed to start Firefox
on the remote machine.

> Is it possible/better to start mythtv-setup from a regular SSH session and
> > in that case how?
> You can tunnel X apps over SSH quite easily.  Just use a command like:
> ssh -X <hostname>
> And then run your X apps. If you need more info, try this:
> http://www.vanemery.com/Linux/XoverSSH/X-over-SSH2.html

I will try that to get forward.
I have used Fedora on my Linux boxes before and must say that VNC work a lot
better (or at least more simple). Nowdays I have switched to Kubuntu on all

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070824/eef58421/attachment.htm 

More information about the mythtv-users mailing list