[mythtv-users] mythtv-setup and X forward

Joe Ripley vitaminjoe at gmail.com
Fri Aug 24 14:59:43 UTC 2007

On 8/24/07, Joacim J <jocke4news at gmail.com> wrote:
> I have tried running it over VNC but get:
> ======================================
> root at frodo:/home/joacim#
> /usr/local/mythtv_svn_r14230/bin/mythtv-setup
> Xlib: connection to ":1.0" refused by server
> Xlib: No protocol specified
> mythtv-setup: cannot connect to X server : 1.0
> ======================================
> How can I run this?

How are you attempting to use VNC?  There are basically two ways to
get VNC access to your desktop.  One is to run the Xvnc server and one
is to use the the VNC module for X.  Perhaps you should take a look at


> Is it possible/better to start mythtv-setup from a regular SSH session and
> in that case how?

You can tunnel X apps over SSH quite easily.  Just use a command like:
 ssh -X <hostname>

And then run your X apps. If you need more info, try this:

Joe Ripley
vitaminjoe at gmail.com

More information about the mythtv-users mailing list