[mythtv-users] LIRC Problem

Brian Wood beww at beww.org
Tue Jan 17 14:34:09 UTC 2006

On Jan 17, 2006, at 7:18 AM, Colin Smillie wrote:

> I'm having the same problem my FC4 system.  I've tried kernel  
> 2.6.14-1.1656_FC4smp and have now fallend back to  
> 2.6.13-1.1532_FC4.  I can't get the /dev/lirc or /dev/lirc0 to  
> appear with either my Hauppauge remote or my MCE_USB.  I'm using  
> the following lirc versions:
> lirc-devices-0.7.0-1.rhfc4.at
> lirc-lib-0.8.0-54_cvs20060107.rhfc4.at
> lirc-kmdl-2.6.14-1.1656_FC4smp-0.8.0-54_cvs20060107.rhfc4.at
> lirc-kmdl-2.6.13-1.1532_FC4-0.8.0-52_cvs20051114.rhfc4.at
> lirc-0.8.0-54_cvs20060107.rhfc4.at
> lirc-lib-devel-0.8.0-54_cvs20060107.rhfc4.at
> dmesg shows:
> lirc_dev: IR Remote Control driver registered, at major 61
> usbcore: registered new driver lirc_mceusb
> /var/tmp/bach-build/BUILD/lirc-0.8.0-CVS/drivers/lirc_mceusb/ 
> lirc_mceusb.c: USB Microsoft IR Transceiver Driver v0.2
> and then messages shows:
> Jan 16 20:19:05 localhost lircd-0.8.0-CVS[2517]: lircd(userspace)  
> ready
> Jan 16 20:19:46 localhost lircd-0.8.0-CVS[2517]: accepted new  
> client on /dev/lircd
> Jan 16 20:19:46 localhost lircd-0.8.0-CVS[2517]: could not get file  
> information for /dev/lirc0
> Jan 16 20:19:46 localhost lircd-0.8.0-CVS[2517]: default_init(): No  
> such file or directory
> Jan 16 20:19:46 localhost lircd-0.8.0-CVS[2517]: caught signal
> I did find /etc/sysconfig/lircd which has a LIRCD_OPTIONS= line in  
> it, which was blank in my configuration.  I've tried inserting -- 
> with-driver=mce_usb and --with-driver=hauppauge with no change in  
> results.  I'm not really sure that /etc/sysconfig/lircd is used by  
> lirc on FC4.  Anyone have any other ideas on where to debug?
The "LIRCD_OPTS" is normally the character device that you want the  
daemon to listen to (/dev/lirc/0 or the like), while "LIRC_OPTS"  
would be "--with-driver=hauppauge" or similar, telling the compiler  
what options to compile in. "with-driver=hauppauge" tells it to  
compile the i2c support, without it it will normally compile only the  
serial support.

I don't know where FC4 stores these options but it looks like you  
have found the LIRCD spot, but you have put the LIRC option there.  
Try putting the character device from a "ls -al /dev/lirc*" listing  
in the LIRCD opts and testing with irw.

Looks like you are very close though.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060117/1eee00ea/attachment.htm

More information about the mythtv-users mailing list