[mythtv-users] myth setup- ivtv problems

Greg greg12866 at gmail.com
Sat Dec 30 22:10:44 UTC 2006

Aaron LaFevers wrote:
> All,
> I'm setting up a mythtv frontend on an old HP.  Im following Jarod's 
> guide over at wilsonet dot com. Need to warn you that I am 100% new to 
> linux and have considerable trouble when I run into problems not 
> addressed in the guide, however I do a lot of reading before asking.  
> I've reached the point where installation of ivtv is required, and did 
> the following:
> # yum -y install ivtv-firmware
> # yum -y install ivtv-kmdl-$KVER
> Then added the following to the end of the /etc/modprobe.conf file:
> # ivtv modules setup
> alias char-major-81 videodev
> alias char-major-81-0 ivtv
> I have a PVR-250 and want to use NTSC, so I didn't add any further 
> lines to modprobe.conf.  I was under the impression that at this point 
> the ivtv driver was installed, and as per Jarod's next step I loaded 
> the driver with:
> # /sbin/depmod -a
> # /sbin/modprobe ivtv
> After the second line was entered I recieved this error mesage:
> FATAL: Module ivtv not found.
> After "# rpm -qa | grep ivtv" it returned " ivtv-firmware-1.8a-10.at 
> <http://ivtv-firmware-1.8a-10.at>"  so i assume it is installed... I 
> even tried Jarod's solution to a different ivtv problem "echo 16384 > 
> /proc/sys/vm/min_free_kbytes" which not surprisingly didn't do a thing 
> for me. 
> I've checked the archives, and from what I have found no one has 
> really answered this question, at least not enough for me to 
> understand what needs to be done.  Help would be greatly appreciated.  
> Let me know if you need more information about my setup. Thanks in 
> advance-
> Aaron
> ------------------------------------------------------------------------
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Aaron, Did you set up the custom environment variable? I had almost the 
same error recently. the solution for me was to set the environment 
variable...If you did perhaps you didn't reboot to set it..It's there in 
the getting your system up to date section.....  The command is below...
 echo "export KVER=\`uname -r\`" >> /etc/profile.d/kver.sh 
Good Luck,

More information about the mythtv-users mailing list