[mythtv-users] yum broken after update

Nick Morrott knowledgejunkie at gmail.com
Mon Dec 11 22:16:33 UTC 2006

On 11/12/06, Jerome Yuzyk <jerome at supernet.ab.ca> wrote:
> I know this isn't about Myth per se, but it's happened to my Myth box
> (Fedora Core 5) in the process of updating my ivtv kernel module, and it
> may have happened to someone else.
> After updating yum-plugin-kmdl to 0.4-5.fc5.at (which also updated
> ivtv-kmdl), trying to update anything with yum gives me this error:
> Traceback (most recent call last):
>   File "/usr/bin/yum", line 29, in ?
>     yummain.main(sys.argv[1:])
>   File "/usr/share/yum-cli/yummain.py", line 138, in main
>     (result, resultmsgs) = base.buildTransaction()
>   File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 402, in
> buildTransaction
>     self.plugins.run('postresolve', rescode=rescode, restring=restring)
>   File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/kmdl.py", line 97, in postresolve_hook
>     kernels = kernels + old_kernels(conduit)
>   File "/usr/lib/yum-plugins/kmdl.py", line 54, in old_kernels
>     for package in conduit.getRpmDB().returnPackages():
> AttributeError: RpmDBHolder instance has no attribute 'returnPackages'
> I haven't been able to find anything about this from Google. I rebuilt my
> RPM database and tried again but still no luck.

If you're using atrpms.net you may want to subscribe to (or at least
regularly read) their mailing lists. This problem has been mentioned
today on the -users list:



MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list