[mythtv-users] Sound broken on one particular channel only (NOT SOLVED)

devsk funtoos at yahoo.com
Fri Dec 8 19:15:59 UTC 2006

I ran mythfrontend with '-v audio' and some difference came up during
testing the bad channel and good channel. The difference is that two
"WriteAudio: Preparing 6144 bytes (1536 frames)" calls are separated by
at most 30ms for good channel and by >150ms (sometimes as high as
250ms) for the bad channel. It just repeats "AO: Broadcasting free
space avail" and "AO: audio waiting for buffer to fill: have 4608 want
6144" during this time. That means the card is not feeding
anything to the 6KB buffer that myth has for audio, for as long as
250ms. No wonder the sound is broken because what it feeds to buffer
ultimately is the next spoken word.... But, why is that happening only for this channel?

One possibility is that myth reduces the size of the buffer to 1kb and
start writing as soon as it is filled. It has 4608 bytes filled
but it doesn't write them because it wants to fill the whole 6KB buffer
and then write. By the time it fills 6kb, its too late for the rest of
the data on the card. I am not sure if it will help or is even feasible. But the question is why is the card not sending
the audio data in a regular fashion on this channel only?

I booted into XP (dual boot machine) and found the same broken sound on "only" that channel. Seems like some device problem because the same channel has good clean sound on TV.

Is there anybody else in the bay area with this card? Can you please confirm if channel 12 sound works for you.


----- Original Message ----
From: devsk <funtoos at yahoo.com>
To: mythtv-users at mythtv.org
Sent: Tuesday, December 5, 2006 5:01:12 PM
Subject: [mythtv-users] Sound cracked on one particular channel only


Normally the sound is pretty good on most of the channels, but on channel #12 (bay area CW) I get cracked sound in livetv as well as recordings (it spoiled smallville last week). I tried the fix in playback settings using "extra buffering" but it doesn't help. Aggressive audio buffering in "general" settings is also checked and it doesn't help either. Un-checking both doesn't do anything. It doesn't matter if I am using ALSA or OSS /dev/dsp in audio settings.

I was wondering if someone knew what the issue might be and what I can do to fix it.


Everyone is raving about the all-new Yahoo! Mail beta._______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org

Have a burning question?  
Go to www.Answers.yahoo.com and get answers from real people who know.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20061208/824155ac/attachment.htm 

More information about the mythtv-users mailing list