[mythtv-users] No sound after upgrade to FC5

Brad Fuller bradallenfuller at yahoo.com
Mon Aug 7 01:50:45 UTC 2006


Dave wrote:
> Brad Fuller wrote:
>   
>> Dave wrote:
>>     
>>>> Since you hear with aplay, you could turn all of them down one by one to
>>>> see which one is the default.
>>>>
>>>> In any case, the setting at:
>>>> Setup>General>Audio
>>>> should be set to "ALSA:default" and you'll be set.
>>>>     
>>>>         
>>> I'm not sure where that setting is - maybe your mythtv is different than 
>>> mine.  In mythtv, the closest setting I can find is in [Utilities/Setup] 
>>> [Setup] [General] [Next] [Next] [Audio output device].  It's set to 
>>> "/dev/dsp", and the other choices in the dropdown are "/dev/dsp1", 
>>> "/dev/adsp", and "/dev/adsp1".  I've tried them all with no luck.  I did 
>>> type ALSA:default in that same box, but it didn't seem to make a 
>>> difference.  Still no sound.  :-(
>>>   
>>>       
>> you're in the right place. If ALSA if compiled in (it's default in
>> ATrpms rpm packages) then  ALSA:default should be there.
>> Perhaps the alsa compile option was unchecked?
>>     
>
> Hello again, Brad.
>
> Now you've really lost me.  "compiled in" to what?  "alsasound" seems to 
> be running (although there's no alsa in "ps -efa"), but I don't know 
> anything about it beyond that:
>
> [root at dave init.d]# service alsasound status
> ALSA sound driver loaded.
> [root at dave init.d]#
>
> As far as I remember, I've compiled nothing.  I just used yum to install 
> everything on this box, including mythtv.
>   
I'm referring to the compile switch for mythtv. But, it doesn't matter.
If you have installed it from yum, then you've installed a package that
someone else has already created for you. I assume you got it from the
ATrpm repo, yes?

Why I mentioned that was because it appears, w/o any digging, that ALSA
is running. It's the default in FC5 and since you can aplay something,
and you say it's running, then it probably is. And, since ALSA:default
was not a selection for audio, that indicates that ALSA is either not
compiled in, or ALSA is not available in your setup.

I think first you have to find out why "ALSA: default" is not a
selection. I don't know why, it is on mine since FC2.  Hmmm... Do you
have live TV sound? BTW: did you install using Jarod's guide?

-- 
brad fuller
sonaural: www.sonaural.com
personal: www.bradfuller.com




More information about the mythtv-users mailing list