[mythtv-users] Problems recording from second tuner

Nick knowledgejunkie at gmail.com
Fri Dec 23 02:05:27 EST 2005

On 23/12/05, Shermann Min <shermann at aya.yale.edu> wrote:
> I have a Myth system (SVN 8152) with an HD-3000 and PVR-250
> tuners. Everything works with my HD-3000 tuner. Tuning,
> recording, everything.
> It's a different story with my PVR-250, however. I had
> some trouble getting this card to work again after upgrading
> to Suse 10, but after a recent post about linking the
> firmware files to /lib/firmware and remembering to set the
> tuner=39 driver option, things are looking good...almost.
> When watching LiveTV on the PVR-250, Myth can tune to all of
> my channels. If I press R to record, it records fine (meaning
> I can pause, skip back/ahead, etc.), so long as I keep
> watching the show. If I exit back into the Myth menus, myth
> stops recording the show. Similarly, if I'm in the program
> guide and press R to record a show, it immediately says the
> show is "Recorded" rather than "Recording." Here are the
> backend logs when I do that:
> -----
> 2005-12-22 22:28:11.427 Reschedule requested for id 129.
> 2005-12-22 22:28:11.538 Scheduled 15 items in 0.1 = 0.10 match + 0.01 place
> 2005-12-22 22:28:11.558 TVRec(2): Changing from None to RecordingOnly
> 2005-12-22 22:28:11.559 ChannelBase: Could not find input: Television on
> card when setting channel 3
> 2005-12-22 22:28:11.559 TVRec(2) Error: Failed to set channel to 3.
> Reverting to kState_None

I'd venture that in mythtvsetup, you have an input called "Television"
specified that does not exist as an input in the ivtv tuner, so MythTV
can't change to it. If you're using the tuner on the PVR-250, the ivtv
input is called "Tuner" (in new ivtv versions) or "Tuner 0". Does
changing this in mythtvsetup help at all?

You can get details from ivtv using 'ivtvctl -a' - should give a list
of all inputs the driver has allocated.


More information about the mythtv-users mailing list