[mythtv-users] BUG: Live TV/PVR250, playback issue on apparent buffer fill

Michael Brown spam-me at houston.rr.com
Sun Sep 26 11:28:50 EDT 2004

Jay R. Ashworth wrote:
>> On Sun, Sep 26, 2004 at 01:40:18AM -0700, Brad wrote:
>>> I was watching a long movie on LiveTV and after about 2 1/2 hrs the
>>> video started to break-up for a few seconds and then started playing
>>> previously buffered footage from probably 2 hrs earlier. It did this
>>> for a few seconds (maybe 15 or 20) and then the video started to
>>> break-up again and eventually went back to the live broadcast. Very
>>> odd.
I've seen something like this myself.


>>> If anyone else has noticed this happening, perhaps they could add
>>> their experiences. It may be good for some others to try to
>>> reproduce this problem on other systems too.
>> Indeed.  But, as has been noted before, be carful about what you
>> apply
>> the label 'bug' to.  :-)  Developers have feelings, too.

IMO this is caused by the ring-buffer getting large and/or NFS version 2
vs. version 3.

AIR, NFS version 2 doesn't like files that are >2GB.  Oddly enough this
only seems to manifest itself within myth when writing a very large file
from a remote front-end (like when ripping a dvd) or seeking past the
2GB position of a file that is being read non-sequentially (like when
skipping ahead or back in the ring-buffer).  Make sure you have the
CONFIG_NFS_V3 set in your kernel config (backend and frontend).

Or you could just change channels every once in a while.  ;-)


More information about the mythtv-users mailing list