[mythtv-users] Problems with ivtvdev_drv

Eggert Thorlacius eggi at menandmice.com
Thu Nov 11 11:53:25 UTC 2004

Thank you, thank you, thank you.

I followed your instructions and managed to compile both the IVTV  
driver and MPlayer (as it turned out, I had forgotten to update the  
kernel source when I upgraded the kernel) and now I can play fullscreen  
videos with "mplayer -vo ivtv".

However, now the X output looks like this:  
http://eggert.thorlacius.com/tv.jpg  Is this because I didn't apply the  
X patch?  FC2 doesn't use XFree86, but Xorg (currently  
xorg-x11-6.7.0-9).  Can I apply this patch to it or do I have to switch  
to XFree86 ?


On 10.11.2004, at 10:26, zardoz at zardoz.ath.cx wrote:

> If you want to compile the ivtvdev_drv.o you need sources for X  
> installed on
> your system.
> I am not very familar with fedora, so I can only explain the 'native'  
> way :
> wget
> zcat ivtv-0.2.0-rc2p.tgz | tar xvf -
> cd ivtv-0.2.0-rc2p/driver/
> make
> make install
> cd ../utils/
> make
> make install
> ===============no you have to choices
> install -c -m 0444 ivtvdev_drv_o  
> /usr/X11R6/lib/modules/drivers/ivtvdev_drv.o
> ===============or
> zcat XFree86-4.3-incr-DMA-06.tgz |tar xvf -
> cd XFree86-4.3-incr-DMA-06/xc/programs/Xserver/hw/xfree86/drivers/ivtv/
> xmkmf /PATH_TO_X_SOURCE/
> ==========find your source with find / -name xf86.h and include the  
> 'xc/'
> make
> make install
> ===================================================
> ===================================================
> pray and reboot the box (cold boot better)
> but even now, the mplayer -vo xv won't work, since we still don't have  
> xv
> support with that driver. try -vo x11, and if this still is choppy,  
> you could
> consider either using 'mythtv /myth/video/mymovie.mpg' (where you  
> would have
> to select the 'use pvr-350 tv-out' in myth settings. OR you download
> wget
> -4.tgz
> zcat MPlayer-1.0pre5-ivtv-osd-4.tgz |tar xvf -
> cd MPlayer-1.0pre5-ivtv-osd-4
> ./configure
> make
> make install
> with this patched version of mplayer you could use -vo ivtv or -vo  
> ivtvosd
> keep in mind that this mplayer would try to access ivtv directly, as  
> the
> xdriver does, so they will fight against each other.
> you have to play with the ivtvfbctl and the global/local alpha  
> settings.......
> hth
> ---z
> On Tuesday 09 November 2004 23:24, Eggert Thorlacius wrote:
>> Hi all
>> I am sorry that I have to keep posting to the list, but I have
>> completely lost sight of what I am doing and I'm just running around  
>> in
>> the dark by now.
>> I tried downloading the source of IVTV to get a new ivtvdev_drv.o  
>> file,
>> as Prash recommended, but I can't get the source to compile (neither
>> from ivtv-0.1.9a.tar.gz nor CVS-LATEST.tar.gz).  I went to the
>> http://membres.lycos.fr/badzzzz/ and downloaded the source of the
>> driver from there, but when I built it, I did not get a ivtvdev_drv.o
>> file, but a bunch of .ko files.  Installing them had no apparent
>> effect.
>> Running mplayer without the "-vo xv" apparently decodes the mpgs in
>> software and my machine can't handle that, so in order to enable the
>> hardware decoding, I need ivtvdev_drv.o.
>> Jarod's Guide says: "Note that the ivtvdev X driver is included with
>> the ck-series ivtv drivers, so no need to fetch it, just use it. Or so
>> I believe. Gotta get my EPIA back up and running..."  What does this
>> mean?  Does the driver from atrpms work (for everyone except me, that
>> is)?  If not, where can I fetch it?  Can someone who has gotten the
>> source to compile send me a copy of the driver?  Do I need a different
>> version of the driver because I'm using PAL?  And once I get the
>> driver, where do I install it?  Why does apt-get install the driver in
>> /usr/X11R6/lib/Server/modules/drivers, where X (apparently) can't find
>> it?
>> There is GeForce2 MX/MX 400 video card with TV-Out in my machine as
>> well.  Do you think that I will have more success if I tried to  
>> connect
>> the TV to that card?  I'd still need to make the PVR-350 handle the
>> decoding, so I'd still need the driver, right?
>> Thanks in advance for any pointers,
>> Eggert
>> On 9.11.2004, at 12:54, Eggert Thorlacius wrote:
>>> On 9.11.2004, at 10:59, Prash wrote:
>>>> As it says you don't have a X driver with Xv support. Remove the -vo
>>>> xv from the command . Are you using the patched mplayer from atrpms?
>>> Yes, I'm using the mplayer that I got from "apt-get install
>>> mythtv-suite".  If I remove the -vo xv from the command, mplayer  
>>> plays
>>> really jerkily and says that my computer is too slow to play video.
>>> Anyway, MythTV uses "mplayer -vo xv" when playing movies from my  
>>> movie
>>> library, so I need to fix this in order to get MythTV to work, right?
>>>> Try using the ivtvdev driver that came with the source.
>>> OK, I'll try that when I get home.  But if I get the latest version  
>>> of
>>> the driver from CVS, will it work with the rest of the components
>>> which I downloaded from atrpms?  Also, is this a known problem with
>>> the driver?  From what I see on this list, most people can just  
>>> follow
>>> Jarods guide and the driver works.  There must be something wrong  
>>> with
>>> my setup, but I can't imagine what.
>>>> What is your videocard make?
>>> It is a Hauppauge PVR 350 (PAL version)
>>> Thanks for the advice
>>> Eggert
>>>> On Tue, 9 Nov 2004 10:12:10 +0000, Eggert Thorlacius
>>>> <eggi at menandmice.com> wrote:
>>>>> Hello
>>>>> I have been trying to install MythTV on a FC2 box with a Hauppauge
>>>>> PVR
>>>>> 350 card (PAL version) with no success for the last few weeks.  I
>>>>> followed Jarod's guide and got to the point where I could see X on  
>>>>> my
>>>>> TV and play TV by catting /dev/video0 to /dev/video16, but when I
>>>>> tried
>>>>> using mplayer to play fullsceen, it quit with the error message
>>>>> "there
>>>>> is no Xvideo support for your video card available"
>>>>> I posted to this list and got no reply, so I decided to swap hard
>>>>> disks
>>>>> and start over.
>>>>> Now I have three different scenarios:
>>>>> * If I try starting X after following sections 1 to 10 of Jarods
>>>>> guide,
>>>>> I get "Failed to load module "ivtvdev" (module does not exist, 0)"
>>>>> * If I move ivtvdev_drv.o from  
>>>>> /usr/X11R6/lib/Server/modules/drivers
>>>>> to
>>>>> /usr/X11R6/lib/modules/drivers, I get "LoadModule: Module ivtvdev
>>>>> does
>>>>> not have a ivtvdevModuleData data object"
>>>>> * And if I install the
>>>>> http://membres.lycos.fr/badzzzz/ivtvdev_drv.o.gz
>>>>> module in /usr/X11R6/lib/modules/drivers, I can start X but mplayer
>>>>> refuses to work ( I do get the error "IVTVDEV(0): FBIOPAN_DISPLAY:
>>>>> Invalid argument" in my Xorg.0.log, but it doesn't stop X from
>>>>> starting)
>>>>> So what am I doing wrong?  What version of ivtvdev_drv am I  
>>>>> supposed
>>>>> to
>>>>> use and where am I supposed to put it?
>>>>> Regards,
>>>>> Eggert Thorlacius
>>>>> _______________________________________________
>>>>> mythtv-users mailing list
>>>>> mythtv-users at mythtv.org
>>>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>>> _______________________________________________
>>>> mythtv-users mailing list
>>>> mythtv-users at mythtv.org
>>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list