[mythtv-users] Repeat problems with ati_remote in 2.6 kernel

Phill Edwards philledwards at gmail.com
Tue Dec 28 23:39:11 UTC 2004

> Yesterday, I upgraded my myth box to a 2.6.10 kernel, from 2.4.26.  Almost
> eeverything has gone very smoothly, with just one outstanding problem.
> I had been happily using the 2.1.1 ati_remote driver from the GATOS
> project, without lirc.  I'm now using the follow-on that's included in the
> 2.6 kernel.
> I noticed that many of the keycodes have changed, but that was no problem:
> I just used xev to get them all, and updated my .xmodmaprc.  One odd thing
> is that I'm no longer getting a keypress from the channel + and - buttons.
> The real problem, though, is the repeat behaviour.  I'm finding that it's
> very easy to accidentally get a double keypress.  If I press 2 or 3 times
> in a row, I'll get 6 or 8 presses.  It makes things pretty hard to
> control.  I'd guess that the repeat functionality that's shown up since
> the old driver is supposed to allow me to hold down a button and get rapid
> repeats, but if I do that, it keeps going well after I stop pressing it.
> Here's what's logged when I load the module:
> Dec 28 13:25:51 myth kernel: ati_remote 2-2:1.0: Input registered: X10 Wireless Technology Inc USB Receiver on usb-0000:00:02.0-2
> Dec 28 13:25:51 myth kernel: usbcore: registered new driver ati_remote
> Dec 28 13:25:51 myth kernel: drivers/usb/input/ati_remote.c: Registered USB driver ATI/X10 RF USB Remote Control v. 2.2.1
> Dec 28 13:25:51 myth kernel: drivers/usb/input/ati_remote.c: Weird data, len=1 ff 00 00 00 00 00 ...
> Has anyone had any luck using the ati_remote driver in 2.6?  Anyone seen
> these kinds of problems, or better yet, solved them?

Have you tried using repeat=0 in the .lircrc? Eg:
    prog = irexec
    button = SRS
    repeat = 0
    config = /usr/local/bin/mythrestart.sh

More information about the mythtv-users mailing list