[mythtv-users] hd2000 / dtvscan / strange output

David George david at thegeorges.us
Thu Dec 9 19:33:14 UTC 2004

On 12/9/2004 2:11 PM, clemens at dwf.com wrote:

>I have yet to see any output from my hd2000 pcHDTV card.
>One thing that might be significant in tracking down the problem 
>is that if I do a 'dtvscan' I get the following output
What driver version are you using?  Some have reported problems using 
the new HD2000/HD3000 drivers with the HD2000 card.  I am using a 
modified version of the HD2000 v1.3 drivers (see 
http://thegeorges.us/mythtv/ ).

>with no channels identified.
What HDTV channels do you have in your area?  Do you get anything if you 
use dtvsignal /dev/dtv xx (where xx is the DTV channel number)?

>The /dev/dtv comment is OK (?) in that /dev/dtv -> /dev/dtv0 and all
>other /dev/dtv? give an error on trying to open them.  Since the bttv
>devices are /dev/video1, etc, I would have EXPECTED to find /dev/dtv1,
>but its not alive...
bttv devices start with /dev/video0, the hd2000 starts at /dev/dtv0 
(/dev/dtv is usually a symlink to /dev/dtv0).  I am sure someone will 
pop up and say I am wrong and there are so many others and not 
necessary, so I'll beat everyone to it.  You have tried the other 
devices so that isn't the problem.

>In any case, the thing that seems just WRONG is the line
>    dtv unit v4l minor = 1297516246
>I see different 'random numbers' with different versions of dtvscan.
>I would ASSUME this should be something in the range 0-255.
>Any thoughts?
Yep, that minor number does seem wrong.


More information about the mythtv-users mailing list