[mythtv] help wanted---about lirc application problem

Xi Jiarong XiJiarong at sp.edu.sg
Tue Jul 17 06:13:04 UTC 2007

I compiled MythTV on fedora core 6, and now can use hauppauge remote
control to cotrol mythtv UI properlly.
However, I want to extend this lirc for external application, so I used
irexec.c programming, but got problems:
I tried to use catch each pressed button code for lirc remote control, so
as to use for some external application.
Now, I put lirc_client.c into folder /user/include/lirc/, and modify
irexec.c. (this lirc_client.c is not created after compiling lirc driver?
is this right? )
but I found when I ran my this program always got the following errors:
irexec: could not connect to socket
irexec: No such file or directory
It seems there are some problems about lirc_init();
Moreover, I have used #chmod 777 /dev/lircd;
In fact, I can use this lirc driver for mythtv and used this remote control
properlly, but got the abover problem when trying for external application.
Hope to get your help:)
Any suggestion would be welcome!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20070717/e9ea117f/attachment.htm 

More information about the mythtv-dev mailing list