[mythtv] Watch Recordings is slow with SVN on my Epia [Solved]

Paul Andreassen paulx at andreassen.com.au
Wed Sep 6 12:59:06 UTC 2006


On Wed, 6 Sep 2006 09:37 pm, Daan de Beer wrote:
> Hello All,
>
> As advised, I profiled my system using OProfile, I recompiled MythTV with
> the "profile" type. I also recompiled my Xorg-server with O2 (instead of
> Os) and told Portage (I'm using Gentoo) not to strip the executables.
>
> I created a strace and a profile report using OProfile. But while profiling
> I immediately noticed that the problem is gone! I recompiled the
> xorg-server using Os and the problem was back. So I again recompiled it
> using O2 and the problem is gone. After that I recompiled Mythtv to be
> Release again and still everything works.
>
> So my problem is gone, I thought I would report this back, because other
> people might benefit from this.

A few years ago I tried compiling with -Os for my epia M10000 and found the 
performance to be very poor.  Now I compile with -O3 for all my machines.  As 
far as I'm concerned -Os is pretty useless and should come with a big fat 
warning.

The problem with the xorg-server is probably due to the developers using -O2 
and not testing it with -Os.  It also could be a problem with the compiler

Paul
-- 


More information about the mythtv-dev mailing list