[mythtv] MacOS X MMX yuv420_2vuy Patch

Todd Ignasiak ignasiak at gmail.com
Fri Sep 1 14:18:10 UTC 2006


On 9/1/06, MythTV <mythtv at taoyama.com> wrote:
> Nigel,
>
> Thanks for cleaning up my patch and submitting it.
>
> I'm no longer seeing a crash but I'm seeing a problem on startup or a
> channel change with HDTV.
>
> The live TV freezes and I get a constant "NVP: Timed out waiting for
> free video buffers."
>
> It seems like there is some sort of race condition since if I launch
> without verbose it seems to happen on live TV startup but if I
> startup with a -v all then it can start and playback the starting
> channel but locks up on a channel change.

I built it this morning,  and I saw the same thing.   The first
channel played, then when I changed channels I got a small bit of the
audio on the new channel, but none of the video.  The console log on
the frontend shows:

2006-09-01 10:09:28.783 TV: Changing from None to WatchingLiveTV
2006-09-01 10:09:28.790 Video timing method: USleep with busy wait
2006-09-01 10:09:29.986 AFD: Opened codec 0x2a88b200, id(MPEG2VIDEO) type(Video)
2006-09-01 10:09:29.987 AFD: Opened codec 0x2a890800, id(AC3) type(Audio)
2006-09-01 10:09:30.212 NVP: Enabling Audio
2006-09-01 10:10:40.581 msg: On same multiplex...
2006-09-01 10:10:42.456 AFD: Opened codec 0x28a0600, id(MPEG2VIDEO) type(Video)
2006-09-01 10:10:42.456 AFD: Opened codec 0x2a890800, id(AC3) type(Audio)
2006-09-01 10:10:45.008 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:47.019 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:49.032 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:51.045 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:53.058 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:55.070 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:57.080 NVP: Timed out waiting for free video buffers.
2006-09-01 10:10:59.094 NVP: Timed out waiting for free video buffers.


Also,  I was having an intermittent problem skipping ahead when
playing recorded programs.  Sometimes it will work fine, but other
times the video will completely hang when skipping forward (either
right arrow or down arrow).   I can pretty reliably get it to hang by
hitting a few right arrows in rapid succession, but other times a
single keypress will hang it.       Is anyone else seeing this?


> On Aug 31, 2006, at 8:36 PM, Nigel Pearson wrote:
>
> >> This seems to work fine for me on my Mac Mini (builds and runs OK).
> >
> >       Thanks. 'tis now checked in.
> >
> > --
> > Nigel Pearson, nigel at ind.tansu.com.au|"Look at this!
> > Telstra Net. Eng., Sydney, Australia | Do you think I put this in
> > Office:9202 3900     Fax:  9261 3912 |  to get better reception?"
> > Mobile: 0408 664435  Home: 9792 6998 | Batty - Fern Gully
> > _______________________________________________
> > mythtv-dev mailing list
> > mythtv-dev at mythtv.org
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
> >
>
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
>


More information about the mythtv-dev mailing list