[mythtv] Error compiling mythplugins at 10685

Adolfo R. Brandes arbrandes at gmail.com
Mon Aug 7 20:22:51 UTC 2006

Mytharchivehelper's Makefile wasn't being generated correctly by
configure.  I ran qmake manually for mytharchivehelper (cd
mytharchivehelper; qmake mytharchivehelper.pro), and everything was
fine after that.

I had tried "make distclean" before, "qmake mythplugins.pro", with no
success.  Go figure...

Thanks for your help!


On 8/7/06, Paul Harrison <mythtv at dsl.pipex.com> wrote:

> Something that looks odd in the compiler output is the -DPREFIX=\"\" and
> all the include paths are wrong also which suggests the install prefix
> is wrong. I believe the mythplugins compile reads these setting from the
> mythconfig.mak that is installed when mythtv is installed which is why I
> thought maybe you hadn't installed mythtv before trying to compile the
> plugins.
> I'd try re-running the mythplugins configure script and add a
> --prefix=??? parameter  to make sure the script can find the
> mythconfig.mak. If it still fails check in the mythplugins source
> directory for the 'mythconfig.mak' symlink to make sure it  points to
> the installed mythconfig.mak.

More information about the mythtv-dev mailing list