[mythtv] Error compiling mythplugins at 10685

Chad masterclc at gmail.com
Tue Aug 29 02:43:53 UTC 2006


On 8/7/06, Adolfo R. Brandes <arbrandes at gmail.com> wrote:
> Mytharchivehelper's Makefile wasn't being generated correctly by
> configure.  I ran qmake manually for mytharchivehelper (cd
> mytharchivehelper; qmake mytharchivehelper.pro), and everything was
> fine after that.
>
> I had tried "make distclean" before, "qmake mythplugins.pro", with no
> success.  Go figure...
>
> Thanks for your help!
>
> Adolfo
>
> On 8/7/06, Paul Harrison <mythtv at dsl.pipex.com> wrote:
>
> > Something that looks odd in the compiler output is the -DPREFIX=\"\" and
> > all the include paths are wrong also which suggests the install prefix
> > is wrong. I believe the mythplugins compile reads these setting from the
> > mythconfig.mak that is installed when mythtv is installed which is why I
> > thought maybe you hadn't installed mythtv before trying to compile the
> > plugins.
> >
> > I'd try re-running the mythplugins configure script and add a
> > --prefix=??? parameter  to make sure the script can find the
> > mythconfig.mak. If it still fails check in the mythplugins source
> > directory for the 'mythconfig.mak' symlink to make sure it  points to
> > the installed mythconfig.mak.
> _______________________________________________

I am in the process of testing out SVN in anticipation of 0.20, and am
running into this problem as well.  It looks like the "fix" described
above works (although it's still compiling, but it got past this
error), any way that can be implemented?

-Chad


More information about the mythtv-dev mailing list