[mythtv] Compiling mythplugins - problem with mythmusic

Carl Reynolds mythtv-dev at hyperbole-software.com
Sun Sep 11 19:00:59 UTC 2005


Graeme Hilton wrote:

>Hi all,
>
>I'm compiling Myth from SVN as I run FC4 on x86_64 and for some reason,
>the 0.18 version of mythplugins does not compile for x86_64.  As this is
>my first attempt at doing something like this I'd appreciate a little help.
>
>Firstly, I've got the sources from svn for mythtv, mythplugins and
>myththemes.  I've compiled the mythtv section and that sticks the right
>binaries in the right places and seems to work (apart from some DVB
>problems, but that's for another post).
>
>Myththemes goes fine as well.  Now, mythplugins requires several other
>libraries to be installed on the system.  I'd love to be able to use
>mythmusic, but the ./configure script tells me that it requires libmad,
>libid3tag and libcdaudio.  A quick check with yum tells me that I have
>all three of these packages and their -devel counterparts:
>
>libcdaudio.x86_64       0.99.12-4.rhfc4.at     installed
>libcdaudio-devel.x86_64 0.99.12-4.rhfc4.at     installed
>libid3tag.x86_64        0.15.1-3.b             installed
>libid3tag-devel.x86_64  0.15.1-3.b             installed
>libmad.x86_64           0.15.0b-2_1.rhfc4.at   installed
>libmad-devel.x86_64     0.15.0b-2_1.rhfc4.at   installed
>
>This is a guess, but I assume that I require the mad.h, id3tag.h and
>cdaudio.h files that these packages provide to be available in the
>/usr/local/include directory.  Therefore I've created symlinks for these
>files to the /usr/include directory.
>
>Unfortunately this doesn't solve the problem.
>
>Can anyone help me solve this?
>
>  
>
I have built mythmusic and mythdvd on my x86_64 system. At first I ran 
into the dependency problems you seem to be having. Installing the 
-devel packages seemed to solve it for me.

I do notice a difference in the version numbers of libid3tag and libmad. 
On my system, I have the following packages installed:

libcdaudio.x86_64       0.99.12-4.rhfc4.at	same
libcdaudio-devel.x86_64 0.99.12-4.rhfc4.at	same
libid3tag.x86_64        0.15.1b-3.1.fc3.rf	differ
libid3tag-devel.x86_64  0.15.1b-3.1.fc3.rf	differ
libmad.x86_64           0.15.1b-3.1.fc3.rf	differ
libmad-devel.x86_64     0.15.1b-3.1.fc3.rf	differ

You seem to have earlier versions of the packages that differ between 
our systems.

I checked my /usr/local/include directory and there are no *.h files in 
it, so my build is getting the include files from /usr/include.

It might help if you would post the error messages you're getting when 
you try to compile.



Carl.





More information about the mythtv-dev mailing list