[mythtv] [PATCH] DBOX2 Feed Implementation 2005-05-10

John McEleney john at netservers.co.uk
Tue Jun 7 16:48:14 UTC 2005

Hi Levent,

First off, thanks for putting in the time to write this patch. This is a 
*very* cool feature.

Levent Guendogdu wrote:

>>> 2005-05-30 12:52:52.423 Changing from WatchingLiveTV to None
>>> 2005-05-30 12:53:07.421 Couldn't read data from the capture card in 15
>>> seconds.
>>> Stopping.
>>> 2005-05-30 12:53:07.423 DBOX#1: Recorder now offline. Reactivating 
>>> EPG scan

> The next part is more interesting: "Couldn't read data from the 
> capture card in 15
> seconds."
> It seems your dbox does not return any data. Please make sure it runs 
> in SPTS mode and has a recent image. (I recommend yadi-2.x). Also make 
> sure your ucodes are up to date.

I'm using the latest Sportster, and would like to stick with that. I 
haven't got on too well with Yadi. SPTS is enabled, and when I run 
tcpdump or iptraf I can see a steady stream of traffic coming in to the 
Myth box. I do see occasional isolated frames and hear short bursts of 

Incidentally, I've been able to stream to my Xbox (XBMC) from the dbox 
without any trouble at all. This also requires SPTS mode, so I now doubt 
that there is anything wrong with the dbox. Could a ucode problem 
manifest itself as a streaming failure to Myth, but not to XBMC? Does 
Myth need and special decoders to cope with the stream from the dbox? My 
Myth box works very well with my Nova-T freeview card.

I'm probably going to install Gentoo on a spare box I've got lying 
around, just to see if it's a problem with my FC3 box.


More information about the mythtv-dev mailing list