[mythtv] CVS frontend hosed for the last week

Doug Larrick doug at ties.org
Wed Aug 4 20:58:57 EDT 2004

Curtis Stanford wrote:
> I'm using the latest ALSA I can find (1.0.5a). I changed the 
> max-user-freq to 1024 and still no go. I don't know what this RTC video 
> timing method is but I've tried every combination of settings on the 
> Playback options screen to no avail. If anyone else is using an Epia 
> M10000 with the latest CVS please let me know.

RTC video timing is using Linux's /dev/rtc programmable timer interrupt 
to help Myth determine how long it should display each frame of video. 
Your debug output is suggesting that it is set up to do this job 
properly.  The way you're using it, Myth uses audio as the timebase, 
meaning it plays the audio at 1x speed and adjusts the timing of the 
video frames to match.

You might try turning on the "use video as timebase" option and see if 
that changes matters at all.  This setting plays the video at 1x speed 
and changes the audio speed to keep it in sync.

You might also try changing the permissions on /dev/rtc so your Myth 
user can't read/write it ('chmod a-rw' /dev/rtc as root), which will 
cause Myth to fall back to the (less accurate) sleep w/ busy-wait timing 
method, but will rule out a bug in the RTC timing method.

I suspect that something is wrong with your audio output.  If your audio 
output device is ALSA:<something>, try changing it to not use the ALSA: 
part (or vice versa).  You might also try 'mythfrontend --verbose audio' 
and see if it tells you anything useful.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 256 bytes
Desc: OpenPGP digital signature
Url : http://mythtv.org/pipermail/mythtv-dev/attachments/20040804/3fe26304/signature.pgp

More information about the mythtv-dev mailing list