[mythtv] Small MythTV issues

Christian Hack christianh at pdd.edmi.com.au
Wed May 7 18:55:48 EDT 2003

Basically got my box all going great now except for some minor issues
related to the interface.

1) Pressing return in EPG doesn't work to get to the extra information
screen. The way I understand it spacebar and return/enter should be
interchangeable. I noticed this once I started using my Pinnacle PCTV remote
since the config file supplied uses enter/return for the middle button.
Every other thing seems to accept Enter/Return OK though. Pressing either I
or space on the keyboard correctly takes me to the extra info but even
enter/return on the keyboard doesn't.

Quite annoying when everything else works off the middle button. Anyone else
seen this?

This code in (line 238 in guidegrid.cpp) looks like it should be doing the
right thing but it doesn't seem to work on my RH8 and Wmaker config.

    accel->connectItem(accel->insertItem(Key_I), this, SLOT(displayInfo()));
    accel->connectItem(accel->insertItem(Key_Space), this,
    accel->connectItem(accel->insertItem(Key_Enter), this,

actually in the process of writing this, I have worked at that adding the

    accel->connectItem(accel->insertItem(Key_Return), this,

with the above three fixes that problem. ... not really worth creating a
diff is it? I can if you really want though.

2) Ditto for selecting music in the mythmusic selector. It only seems to
accept space to check/uncheck boxes, although this code seems legit.

    space_itemid = accel->insertItem(Key_Space);
    enter_itemid = accel->insertItem(Key_Enter);
    return_itemid = accel->insertItem(Key_Return);
    accel->connectItem(space_itemid, this, SLOT(selected()));
    accel->connectItem(enter_itemid, this, SLOT(selected()));
    accel->connectItem(return_itemid, this, SLOT(selected()));

So it kinda looks like the RH8/Wmaker/QT I am using are doing something
suss. I do only have QT 3.0.5 (i.e. not 3.1 which I keep seeing warnings
about while compiling). Could that be the problem? In some of the other bits
of code it seems like it's looking for a char space (i.e. ' '). I don't
really understand the Key_Space bit though but it seems to come from QT...

Alternatively I could send a space instead of an enter, but I prefer the
middle button to be an enter key for anything else I might happen to run.

This appears to a different problem to the first solved one.

3) And a suggestion - I was recording something late one night, and it
seemed that my box crashed/rebooted (probably unrelated to Myth... might
have been a power outage). When it came back up it didn't try to keep
recording. Should it have kept going? If a box boots up in the middle of a
recording period should it start and/or try to append to any file that is
already there?

Thanks (particularly if you made it this far reading)

Christian Hack

More information about the mythtv-dev mailing list