[mythtv-users] mythfilldatabase failing

Mary Strimel mary.strimel at gmail.com
Sun Jan 31 01:40:41 UTC 2021

On Sat, Jan 30, 2021 at 2:13 PM Mary Strimel <mary.strimel at gmail.com> wrote:

> On Sat, Jan 30, 2021 at 1:21 PM Mike Perkins <mikep at randomtraveller.org.uk>
> wrote:
>> On 30/01/2021 18:04, Jan Ceuleers wrote:
>> > On 30/01/2021 18:51, Mary Strimel wrote:
>> >> It does not have a </tv> element:
>> >> mary at mythbox:~$ tail /home/mythtv/.mythtv/FIOS.xmltv
>> >> database=/home/mythtv/.xmltv/SchedulesDirect.DB
>> >> lineup=VA65087:X
>> >> 3rdparty-metadata=enabled
>> >> mythtv-categories=enabled
>> >> station-logo-order=
>> >>
>> >> But FWIW, neither does my working file for my other lineup:
>> >> mary at mythbox:~$ tail /home/mythtv/.mythtv/Antenna.xmltv
>> >> database=/home/mythtv/.xmltv/SchedulesDirect.DB
>> >> lineup=USA-OTA-22204
>> >> 3rdparty-metadata=enabled
>> >> mythtv-categories=enabled
>> >> station-logo-order=
>> >>
>> >> Should I just plug something in, and if so, what?
>> >> Thanks.
>> >
>> > I'm afraid that neither of those files are XMLTV files. I don't know
>> > what they are, but they're not in the XMLTV format.
>> >
>> > I use the SD JSON grabber myself, so not the SQlite grabber.
>> >
>> Those are the config files the SD programs use. The error refers to the
>> XML files that these
>> programs should have downloaded. Try tailing one of those.
>> Thank you - after I run the grabber on a standalone basis, weirdly there
> does not seem to be a myth tmp file:
> mary at mythbox:/home/mythtv/.mythtv$ ls /tmp/myth*
> ls: cannot access '/tmp/myth*': No such file or directory
> However, at the end of all the messages in the console, the final line is
> "</tv>" which seems like a good sign.
> The messages from mythfilldatabase when run with the verbose flag indicate:
> 021-01-30 13:58:04.846973 I  Lineup VA65087:X is no longer configured in
> your account at Schedules Direct.
> 2021-01-30 13:58:04.846986 I  Please run tv_grab_zz_sdjson_sqlite
> --manage-lineups to manage your Schedules Direct lineups,
> 2021-01-30 13:58:04.847000 I  and/or tv_grab_zz_sdjson_sqlite --configure
> to change the configured lineups.
> What exactly does it mean that a lineup is "no longer configured in your
> account at Schedules Direct?" I logged on to Schedules Direct and the
> lineup still appears in my account.  When I tried running the grabber with
> --manage-lineups as directed, I reinitiated the grabber's database but
> didn't change any lineups. The grabber then threw this error:
> Fatal error obtaining lineups: HTTP response code was not successful: 403
> Please re-run tv_grab_zz_sdjson_sqlite --manage-lineups and/or
> tv_grab_zz_sdjson_sqlite --configure
> mary at mythbox:~$ su mythtv -c "tv_grab_zz_sdjson_sqlite --configure"
> I then ran the grabber with the --configure option and accepted all the
> defaults, but when I ran mythfilldatabase I got the exact same errors.
> Any idea on how I can get Schedules Direct and the grabber to behave
> properly?

Narrowing the issue, I found that I am able to get listings if I run
mythfilldatabase as regular user mary, but I get the Schedules Direct
lineup error if I run it as user mythtv. I thought the grabber was supposed
to be used and configured as user mythtv though, and mythfilldatabase run
as that user also. What should I do? Is there a way to tell mythtv to run
mythfilldatabase as a regular user?
I compared the FIOS.xmltv files under /home/mary and /home/mythtv. I
thought I'd caught the issue when I noticed that the first file had both
lineups listed (OTA and cable) and the second had only the cable lineup.
But when I conformed the files to make the second match the first, I still
get the error when I run mythfilldatabase as user mythtv. this sounds crazy
but is it possible that user mythtv is not able to create the required /tmp
file for that lineup.

> --
>> Mike Perkins
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://lists.mythtv.org/mailman/listinfo/mythtv-users
>> http://wiki.mythtv.org/Mailing_List_etiquette
>> MythTV Forums: https://forum.mythtv.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210130/1ec82609/attachment.htm>

More information about the mythtv-users mailing list