[mythtv-users] mac build

John Hoyt john.hoyt at gmail.com
Wed Jan 27 23:47:54 UTC 2021

On Wed, Jan 27, 2021 at 5:00 PM John Pilkington <johnpilk222 at gmail.com>

> On 27/01/2021 20:57, John Hoyt wrote:
> > Well, I tried edit mode from mythvideo and recordings (I hacked the bad
> > recording into my mythbackend replacing an old recording with the bad
> > video).  Unfortunately, I was unable to reproduce the segfault with
> > either cutlist editor mechanism.  Basically everything just worked for
> me...
> >
> > I'm curious if there's some other underlying issue that's creating the
> > segfault.
> >
> > James, have you tried telling mythbackend to rebuild the seektable? I
> > think the command is:
> >
> >     mythtranscode --buildindex --allkeys --showprogress
> >     --infile /path/to/file (for a recording)
> >     mythtranscode --video --buildindex --allkeys --showprogress
> >     --infile /path/to/file (for mythvideo)
> I have had tickets about seektable regeneration in the past, and suspect
> that the most recent work on it has used the form
> mythcommflag --rebuild --file ccccc_yyyymmhhmmssxx.xxx     for
> recordings, or
> mythcommflag --rebuild --video  /may/need/full/path/to/file  for videos
> Those commands also reset the file size.  I've used them in scripts for
> years.  HTH...

Thanks John - I'm going to have to borrow that trick on some of my
transcode scripts.

James, another thought in helping isolate the issue is trying to edit the
file from mythvideo.  I.e. copy it to wherever you store you movies files,
tell myth to repair its seek table with John P's commands (or the ones I
suggested earlier) then try to edit the file.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210127/e8459553/attachment.htm>

More information about the mythtv-users mailing list