[mythtv-users] mac build

John Hoyt john.hoyt at gmail.com
Wed Jan 27 20:57:41 UTC 2021

Well, I tried edit mode from mythvideo and recordings (I hacked the bad
recording into my mythbackend replacing an old recording with the bad
video).  Unfortunately, I was unable to reproduce the segfault with either
cutlist editor mechanism.  Basically everything just worked for me...

I'm curious if there's some other underlying issue that's creating the

James, have you tried telling mythbackend to rebuild the seektable? I think
the command is:

mythtranscode --buildindex --allkeys --showprogress --infile /path/to/file
(for a recording)
mythtranscode --video --buildindex --allkeys --showprogress
--infile /path/to/file (for mythvideo)

What database and version are you running on your backend?  Perhaps there's
a mysqlclient mismatch or bug entering into the fray.

If memory serves, I believe I built older versions (and so did the scipr)
with mysql-10.2 for the python stuff and mysql57 for mysqlclient /
qt4-mysql-plugin.  This mismatch issue was due to some macports not
supporting mariadb10.2 or later or mysql8.  I'm working these issues out
with the macports folks currently and will post updated builds based on
mysql8 (going with the "official" mythtv database and what I run on my
backend...) when everything is in place.

...the Big Sur version that I'm using (and posted to sourceforge) is built
with mysql8 on pre-releases of the macports qt5-15.2 and
py-mysqlclient +mysql8 ports

Mark - any other thoughts on what could be causing the segfault?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210127/204c2a73/attachment.htm>

More information about the mythtv-users mailing list