[mythtv-users] Can't enable plugin - MythMusic

Mary Strimel mary.strimel at gmail.com
Tue Oct 20 00:34:44 UTC 2020


On Mon, Oct 19, 2020 at 6:24 PM Bill Meek <keemllib at gmail.com> wrote:

> On 10/19/20 5:03 PM, Mary Strimel wrote:
> >
> >
> > On Mon, Oct 19, 2020 at 5:42 PM Bill Meek <keemllib at gmail.com <mailto:
> keemllib at gmail.com>> wrote:
> >
> >     On 10/19/20 4:29 PM, Mary Strimel wrote:
> >     > You have an error in your SQL syntax; check the manual that
> corresponds to your MySQL server version for the right syntax to use near
> >     'default,
> >     >  MODIFY filename varchar(255) CHARACTER SET utf8 NOT NULL default
> ''' at line 1#012 #012new version: 1016
> >
> >     Sounds like an old version. mythfrontend --version will tell you
> >     what you're running on (unless the distribution changes it.)
> >
> >
> > Thank you - here is the info for my version:
> > mary at mythbox:/var/log/mythtv$ mythfrontend --version
> > Please attach all output as a file in bug reports.
> > MythTV Version : v31.0-v31.0
> > MythTV Branch : fixes/31
> > Network Protocol : 91
> > Library API : 31.20200101-1
> > QT Version : 5.12.5
> >
> >     The fix for that error was released July 16th 2020.
> >     commit 167c8d56 Plugins/dbcheck: Replace CHARACTER SET 'default'
> with 'utf8'
> >
> >
> > Given that I already have version 31, how do I get the post-July 16
> version? Must I compile from source?  If so, I might need to scrap this
> > plugin. My remote frontend is running on an android TV and I have never
> compiled anything for that platform before, not sure I want to try.
>
> If you were a 'buntu user, then I'd do this:
>
> sudo add-apt-repository ppa:mythbuntu/31
> sudo apt update
> sudo apt dist-upgrade
>
> I don't speak Mint, but a search for: linux mint ppa returned this
>
>
> https://www.pcworld.com/article/2942171/how-to-use-ppas-to-install-bleeding-edge-software-in-ubuntu-and-linux-mint.html
>
> If that works, you don't need to build from source.
>

Thank you - yes, I enabled the PPA that you suggested from my "Software
Sources" and installed the recommended version of myth, then restarted
mythbackend. The database upgraded properly for mythmusic and now the
plugins appear properly on my local frontend. Yay!

BUT I still need help to get them showing up on my remote frontend on the
android TV.  To install myth on the TV, I followed the excellent
instructions here <https://www.mythtv.org/wiki/Android> and I downloaded an
apk file from here
<https://dl.bintray.com/bennettpeter/generic/mythtv_31/android_32/>.
Unfortunately I had to use the older of the 2 files (31.0.51) because the
later file gave me an error -- basically adb did not recognize it as a
proper apk, although the other one worked fine.  It runs, it just doesn't
see the plugins.

Is there any other way to get the 31.0.51 frontend to see these plugins?


> --
> Bill
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20201019/3f0a34cc/attachment.htm>


More information about the mythtv-users mailing list