[mythtv-users] Conflict between mythtv-libs and mythffmpeg packages on Fedora

Stephen Worthington stephen_agent at jsw.gen.nz
Tue Jun 23 05:34:23 UTC 2020

On Mon, 22 Jun 2020 15:05:51 -0500, you wrote:

>On 5/31/20 12:31 PM, John Pilkington wrote:
>> If you don't want to wait, you could probably upgrade a fully updated 
>> Fedora 30 system using --allowerasing and --skip-broken, ignoring any 
>> complaints about MythTV.  Then, with a Fedora 31 system that boots 
>> reliably, enable rpmfusion-testing and update MythTV.  But YMMV...
>Update: I'd been experiencing the same issue as the original poster:
>Error: Transaction test error:
>   file /usr/lib64/libmythavutil.so.56 conflicts between attempted 
>installs of mythtv-libs-30.0-12.20190904git5cde0578d8.fc31.x86_64 and 
>Today I made another attempt to run dnf system-upgrade download 
>--refresh --releasever=31...it failed with the same error. Then I 
>discovered that it was pulling mythffmpeg from rpmfusion-free-updates 
>versus rpmfusion-free for all other myth* packages. I disabled 
>rpmfusion-free-updates and ran dnf system-upgrade...success!
>New issue, though: all recordings I've tried playing back with 
>mythfrontend play at something like double speed with no audio. Never 
>seen that one before...

There has been a major update to the rendering code in v31 - maybe you
need to change the settings to something that is supported in this
version if the exact way you were doing it has gone away.

More information about the mythtv-users mailing list