[mythtv-users] HD playback problem w/ kernel version

Tim Draper veehexx at zoho.com
Sat Feb 9 12:48:01 UTC 2019

 ---- On Tue, 05 Feb 2019 13:56:26 +0000 Mark Brown <mbrown at wheelgroup.org> wrote ---- 
 > Hello all,
 > Been having HD playback problems with a Fedora 28/29 frontend since kernel 4.19.  The problem exists with HD TV (hdhr) or HD video playback.
 > Frontend version is 29.1-25 and is on an intel nuc, i915 video chipset, hdmi out, 'Option "AccelMethod" "sna"' is set, "VAAPI  normal" enabled in mythfrontend.  
 > System works fantastic with kernel versions up to 4.18.16-300 but anything later in the 4.19/4.20 series and HD playback stutters terribly (audio and video). 
 > Anyone seeing similar or have a pointer of where to look?
 > Thanks! -mark _______________________________________________ 
 > mythtv-users mailing list 
 > mythtv-users at mythtv.org 
 > http://lists.mythtv.org/mailman/listinfo/mythtv-users 
 > http://wiki.mythtv.org/Mailing_List_etiquette 
 > MythTV Forums: https://forum.mythtv.org 
you might be onto something here. i too have been having issues.
when in a HD recording, try menu > video > advanced > video scan > manually set 'Progressive'. and see if that improves things.

just tried it on my recently rebuilt FC29 laptop - out of box works fine. aside from the fact vaapi isnt enabled on FC29 iso, you have to manually install the libva-intel-drivers (and libva-tools why not; 'sudo vainfo' to confirm operation) enable the VAAPI decoder in mythtv video playback settings and things go wrong.

also had it on primary FE (see thread 'v30 unsmooth playback' recently) and a reinstall seems to have fixed it. turns out it could be i dont have the vaapi drivers installed on it.

More information about the mythtv-users mailing list