[mythtv-users] libva-drm.so.1

Gary Buhrmaster gary.buhrmaster at gmail.com
Thu Jun 14 14:29:00 UTC 2018


On Tue, May 29, 2018 at 1:40 PM Rick <rick at laity.ca> wrote:
>
> I just upgraded to F28 and receive the following when trying to start
> mythbackend .29 - error while loading shared libraries: libva-drm.so.1:
> cannot open shared object file: No such file or directory
>
> libva-2.1.0-1.fc28.x86_64 is installed.

That is the "new" VA-API 1.0 (shipped in F28 as libva-2) which
breaks API/ABI compatibility with the older versions.  It ships
libva-drm.so.2  (not ...1).

> I compiled mythbackend myself, it completed normally and I re-ran
> ansible in case any dependencies had changed.

Did you compile (and make install) in F28?  If so,
the next thing to check is to see if (in your install
locations, or possible elsewhere from previous
installs) you have any legacy libmyth* libraries
from the previous Fedora OS which you did not
properly remove.  The error suggests there are
old libraries somewhere, since a new compile
should require/load libva-drm.so.2 (and not .1).


More information about the mythtv-users mailing list