[mythtv-users] Parts of mythtv can access DB, others can't. Version 30.

Bill Meek keemllib at gmail.com
Mon Jun 4 00:08:18 UTC 2018

On 06/03/2018 04:19 PM, Ian Richardson wrote:
> Tried that. Didn't work. Also tried ensuring I can log in as the mythtv
> user via (as well as, and changing the DB Host in
> mythtv-setup to No luck there, either. mythfrontend,
> mythfilldatabase, mythtv-setup all fail to talk to the DB. The backend is
> fine. (I remembered an old bug where anything other than would
> fail, and I thought that might have resurfaced.)
> I found /usr/share/mythtv/config.xml and, on the chance mythtv-setup might
> have been trying to use that, amended the IP here from to
> 192168.1.234. No dice.
> Mind you, I've just used VLC to watch a recording made by the local backend
> (FE, BE, and DB are all local), as it was recording... All OK.
> The debug just isn't giving me enough. How can I find out exactly how those
> failing parts are trying to talk to the DB? Guess I've got to look at the
> source... or localhost is correct for a backend that also hosts the DB.
Sockets, as opposed to TCP will then be used to communicate with the DB.

The logs will tell you the configuration directory in use, look for:

      ... Using configuration directory _____________

The config.xml file will be there (although, it may be a link to the
actual file.) If the backend is running, as you've mentioned, then
the credentials should match. diff {~mythtv,~}/.mythtv/config.xml
usually works. But take care to see if any MythTV product sets


More information about the mythtv-users mailing list