[mythtv-users] systemd suddenly won't start backend (sort of) FIXED

Robin Gilks g8ecj at gilks.org
Mon Apr 30 04:38:16 UTC 2018

> ...
> On 04/27/2018 08:31 AM, Michael T. Dean wrote:
>> Most likely a different environment (though not necessarily/likely
>> PATH).  Your user's environment is properly configured--has a good
>> $HOME,
>> which has a good $HOME/.mythtv/config.xml (based on "su -c mythtv
>> mythbackend" working).  I'm guessing that the systemctl environment
>> isn't set
>> up right (anymore).  Compare the logs and look at the "Using
>> configuration directory" lines...
> And ...
> systemctl cat mythtv-backend.service will show what's in play. If the OP
> manually
> changed things in /lib/systemd/system rather than making them in
> /etc/systemd/system,
> then the package manager could have released a new version that overwrote
> the changes.
> systemctl edit [--full] is useful if the above is true.

Thanks for the input everyone - it seems to have corrected itself!!

After running from a terminal for another 24 hours I tried the systemctl
command again and it worked fine. No idea what is going on but at least I
have a terminal session back ;)

Starting from boot is unlikely to be an issue as I reboot so rarely - it
was the failure to start from the command line some hours after a reboot
that flummoxed me!

Robin Gilks

More information about the mythtv-users mailing list