[mythtv-users] Backend tuning issues with Fedora 28 and Mythv 29

Jerry mythtv at hambone.e4ward.com
Wed Apr 4 01:01:27 UTC 2018

On Tue, Apr 3, 2018 at 10:41 AM, Jerry <mythtv at hambone.e4ward.com> wrote:

> I have a backend on Fedora 27 that is working as well as I'd wish.
> Yesterday, I got the itch and decided to try to upgrade to Fedora 28 since
> my desktop upgraded smoothly.  Unfortunately, I ran into issues.
> I managed to tune a lower-numbered channel and record a few minutes with
> Mythweb.  When I tried live tv, my screen froze trying to tune the
> channel.  I thought, maybe, just maybe, my cable company changed something
> between the recordings I did Sunday night and Monday morning.  This did not
> turn out to be the case.  I was able to tune in channel 937 (a HD channel
> with unrestricted CCI flags) with VLC player just fine.
> I built the F28 rpms from a fresh VM just in case there were some critical
> library changes.  I did not get past the errors in mythbackend.
> Since I have had issues like this before, I had taken a Clonezilla backup
> and just restored to F27.  I have no issues with this channel or any others
> I have in my lineup that I tested.  Everything is working under F27.  So
> the upgrade broke something.  Maybe there is a new temporary library
> incompatibility in F27?  I do not know.  Fedora 28 is in beta and maybe I'm
> nuts to try to upgrade it now, but honestly I upgrade at the Beta release
> with just about every Fedora cycle and have few issues.  I'm not recording
> much this week and it seems like a good time to upgrade.
> I then installed a test F28 system on a spare HD on my desktop, connected
> my HDHomerun Prime, and set out to grab logs, figuring that the whole thing
> would just work and I'd be really angry.  But fortunately for my sanity, it
> failed in the same way as before.
> Here is the backend log.  https://pastebin.com/r2iJBqvR
> If anyone sees something I could fix, I'm all ears.  The good news is that
> I'm in the same place I was before the upgrade.
> Oh.  Everything else I run on the box was working fine.  With the
> exception of Kodi.  That's probably fixable though.

Here is a fresh paste from my test machine: https://pastebin.com/ec0wns6J
This is with -v record,playback --loglevel debug.  If anyone has any
suggestions on more things to make verbose, I'm happy to oblige.  I'd like
to figure this out.

I fixed the config.xml error from the last paste but that wasn't making a
difference anyway -- I was able to watch live tv with that misconfigured.
It's fixed now.  BE and FE are on the same machine and the HDHomerun Prime
is connected to my router.  I shut down my regular backend just in case.

I can tune in most channels until the "premium" ones.  By premium, I mean
encrypted but with cci flags free to copy away (as I can do with my F27
backend presently on these channels, like USA HD, AMC HD, etc.).  When I
switch to a "premium" channel, mythbackend freezes and gives the errors
shown in the log.

I was using the schedules direct xml grabber, which is working fine in
F27.  I switched it to the regular Schedules Direct grabber on this test
machine just in case it was a channel issue, but I really don't think this
is the case since the F27 box works perfectly well as-is.

Thanks for any input!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20180403/83737e05/attachment.html>

More information about the mythtv-users mailing list