[mythtv-users] HVR-2200 doesnt work in PCIe Gen 3 slot?

Rajil Saraswat rajil.s at gmail.com
Thu Dec 28 02:36:37 UTC 2017


Hi,

I am trying to use Hauppauge HVR-2200 card in a Supermicro X11SAT-F (https://www.supermicro.com/products/motherboard/Xeon/C236_C232/X11SAT-F.cfm) motherboard which has PCIe Gen 3 slots. Unfortunately, the motherboard is not detecting the card. I have tried moving the card to another PCIe slot but it didnot help. Also, i tried changing the PCIe slot to Gen 1.

I tested the card on another system (GA-880GM-USB3 motherboard) which has PCIe Gen 2 slots and it is working fine,

#lspci -vv

02:00.0 Multimedia controller: Philips Semiconductors SAA7164 (rev 81)
        Subsystem: Hauppauge computer works Inc. WinTV HVR-2200
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 4 bytes
        Interrupt: pin A routed to IRQ 30
        Region 0: Memory at fd000000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at fcc00000 (64-bit, non-prefetchable) [size=4M]
        Capabilities: [40] MSI: Enable+ Count=1/16 Maskable- 64bit+
                Address: 00000000fee0300c  Data: 41a2
        Capabilities: [50] Express (v1) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <256ns, L1 <1us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 75.000W
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap: Port #1, Speed 2.5GT/s, Width x2, ASPM L0s L1, Exit Latency L0s <4us, L1 <64us
                        ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
        Capabilities: [74] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [7c] Vendor Specific Information: Len=84 <?>
        Capabilities: [100 v1] Vendor Specific Information: ID=0000 Rev=0 Len=060 <?>
        Capabilities: [160 v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb:    Fixed- WRR32- WRR64- WRR128-
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
                        Status: NegoPending- InProgress-
                VC1:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable- ID=0 ArbSelect=Fixed TC/VC=00
                        Status: NegoPending- InProgress-
        Kernel driver in use: saa7164
        Kernel modules: saa7164


Supermicro says that the card may not be compatible to the latest chipset. Is anybody using this in a Gen3 slot?

Thanks,

Rajil



More information about the mythtv-users mailing list