[mythtv-users] mythweb blank page after upgrade

paul thannet at gmail.com
Sat Jan 17 19:11:14 UTC 2015

On 17/01/15 18:35, Michael T. Dean wrote:
> On 01/16/2015 02:46 PM, paul wrote:
>> On 16/01/15 16:13, Michael T. Dean wrote:
>>> On 01/16/2015 09:33 AM, paul wrote:
>>>> Hi anyone else having this problem? Have this error in the apache 
>>>> log :-
>>>> [Fri Jan 16 13:50:48.006480 2015] [:error] [pid 1240] [client 
>>>>] PHP Fatal error:  Call to a member function 
>>>> query_col() on a non-object in 
>>>> /usr/share/mythtv/mythweb/includes/utils.php on line 59, referer: 
>>>> http://localhost/mythweb/
>>> Usually due to broken mythweb.conf , and specifically the database 
>>> connection information, or due to MySQL permissions problems (i.e. 
>>> such as not allowing database access from
>>> Mike
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://lists.mythtv.org/mailman/listinfo/mythtv-users
>>> http://wiki.mythtv.org/Mailing_List_etiquette
>>> MythTV Forums: https://forum.mythtv.org
>> I restored the original mythweb.conf file from prior to doing the 
>> last updates, and then tried it's true address :-
>> [Fri Jan 16 19:34:55.669296 2015] [:error] [pid 10637] [client 
>>] PHP Fatal error:  Call to a member function 
>> query_col() on a non-object in 
>> /usr/share/mythtv/mythweb/includes/utils.php on line 59, referer: 
>> Which seems to point to this line in utils.php :-
>> $cache[$h][$field] = $db->query_col('SELECT data
>>                                                        FROM settings
>>                                                       WHERE value=? 
>> AND hostnam$
>>                                                     $field);
>> Mythstatus works fine, so does PHPmyadmin, and a few other things I 
>> have running on this Mythbuntu .27
>> Way above my knowledge level. Even went so far as to remove mythweb 
>> and reinstall via the mythbuntu control panel. Still the same issue?
> And that's exactly the error you would get if $db was invalid, for 
> example, if your database connection information in mythweb.conf were 
> incorrect or if your MySQL permissions were incorrect and refused to 
> allow the login for the specified user, with the specified password, 
> from the particular host name/IP address used to attempt the 
> connection from MythWeb to the MySQL server...
> Make sure you're using an appropriate mythweb.conf from the version of 
> MythTV/MythWeb you're using, and verify its connection information and 
> that a connection can be made using mysql command line client from the 
> MythWeb host and specifying the user (-u), password (-p), and 
> hostname/IP address (-h).
> Mike
Hi Mike, thanks for all the help, with your suggestion and a better idea 
what I was looking for, it turned out that the mythweb.conf as you 
suggested was having problems with the db connection, in that it was 
missing the server name (I put in localhost which solved it)

Thank you again for your help, appreciated.


More information about the mythtv-users mailing list