[mythtv] Crash on leaving mythtv-setup in today's master (F31)

John Pilkington johnpilk222 at gmail.com
Wed Jul 8 11:56:08 UTC 2020

On 08/07/2020 04:25, David Hampton wrote:
> On Tue, 2020-07-07 at 16:15 +0100, John Pilkington wrote:
>> On 03/07/2020 23:34, John Pilkington wrote:
>>> On 03/07/2020 22:51, David Hampton wrote:
>>>> I just tried running mythtv-setup again, deleted all capture
>>>> cards and
>>>> video sources, reinput that info, and scanned for channels.  I
>>>> don't
>>>> get a crash.
>>>> Is it possible for you to send me a stack trace?
>>>> David
>>> If it isn't a general problem, sorry for the noise.  I started
>>> mythtv-setup, got the UI display, and everything looked normal; I
>>> didn't
>>> change anything, but it crashed on exit, several times, and with
>>> the
>>> same errors.  But after several attempts to run the backend, setup
>>> worked and the frontend is now looking ok (when running with
>>> localhost).
>>> Gary's packages include debug stuff but I've not used it.
>>> Something
>>> else to try.
>>> John
>> I thought this had gone away after I reset parts of my DB access
>> (details on the users list), but I'm now seeing it in two Fedora 31
>> systems running recent Master, 0a07cb3 and e05a8a8.  They crash on
>> attempting to enter the General tab, but the back and frontends seem
>> ok.
>>    With my SL7.8 system, also on e05a8a8 but with MariaDB 5.5.65,
>> mythtv-setup continues as expected and it all works.
> I think I found and fixed the problem. There were a couple of iterators
> over the channel list that still assumed the list was terminated with a
> null entry. Whether or not MythTV would crash depended on whether or
> not the memory immediately after the last entry was zero.
> Please update and see if the problem still occurs.
> David
I have installed 32.Pre.652.gcfd2eb7...  rpms on both the Fedora 31 
systems that were affected.  The problem has gone away.  Thank you.

John P

More information about the mythtv-dev mailing list