[mythtv] Does Myth Now Require Qr 5.3?
mythtv at love2code.net
Wed Apr 25 04:13:04 UTC 2018
On Tue, 2018-04-24 at 19:56 -0400, Peter Bennett wrote:
> On 04/24/2018 10:57 AM, Ken Mandelberg wrote:
> > Configure only looks for 5.2, but when I tried to compile the
> > latest
> > trunk
> > playbackbox.cpp: In member function ‘void
> > PlaybackBox::UpdateUIRecGroupList()’:
> > playbackbox.cpp:1346:5: error: ‘QSignalBlocker’ was not declared in
> > this
> > scope
> > QSignalBlocker blocker(m_recgroupList);
> > QSignalBlocker was introduced in Qt 5.3.
> > This was on a older Ubuntu 14.04 box, and Ubuntu 14.04 only has
> > packages up to 5.2.
> > TI am reluctant to update the OS. the box has some older graphics
> > hardware that works quite well with
> > Myth, but I wonder how well it will be supported in newer Ubuntu.
> > _______________________________________________
> This is a recent change (April 16th). I will remove the
> and replace it with equivalent code that is QT 5.2 compliant. In the
> meantime you can build off the prior commit a3ae3a82 or wait until I
> make the change (next couple of days).
Please wrap these changes with the conditional:
#if QT_VERSION < QT_VERSION_CHECK(5,3,0)
We should continue to use the QSignalBlocker class in releases where
IIRC, the support policy for MythTV is the last two Ubuntu LTS
versions, which today includes 14.04 and Qt 5.2. Ubuntu 18.04 LTS is
slated for release later this week, which would bump the minimum
required Qt version to 5.5.1. The only other OS release that would be
affected by that higher minimum Qt version is Debian Jesse, which is
currently at Qt 5.3.2. Fedora >= 23, Debian >= 9 (aka Stretch), Ubuntu
>= 16.04, and FreeBSD >= 10 all provide Qt 5.5 or later. I'm not
proposing that we bump the Qt minimum version on the day Ubuntu 18.04
releases, but it will definitely happen by the time MythTV 30 releases
More information about the mythtv-dev