[mythtv] Problem with 0.28 remote frontend

Peter Bennett pgbennett at comcast.net
Sun Apr 17 19:59:43 UTC 2016

Hi Devs

Here is the situation:

mythbackend is up and running.
Install a frontend on a different machine, on the same network.
There is no config.xml on the new frontend.
Start mythfrontend.

With 0.27 the frontend would do a network scan, find the backend, find
out the database password from the backend, create a new config.xml for
itself, then start up. If it could not find the backend, it would prompt
for the database credentials, setup the config.xml from them, and then
start up successfully.

With 0.28 the frontend prompts for country and language, then fails with
a segmentation fault. The log shows that it tried several times to
connect to a backend on; which is incorrect.
This is not user friendly behaviour.
If I run mythtv-setup on that frontend it gives me the prompts for
database credentials and creates the config.xml, then goes into backend
setup. After exiting that I can run the frontend. This is not correct
procedure since you should not run the mythtv-setup on a frontend only

Another way to resolve it is by copying the config.xml from the backend
to the frontend, then everything works. A new user will not know how to
do that.

Is there a bug here? Should I report it or have I been doing something


More information about the mythtv-dev mailing list