[mythtv] More rpm-building questions

John Pilkington J.Pilk at tesco.net
Mon Apr 13 21:55:18 UTC 2015

On 13/04/15 17:24, John Pilkington wrote:
> After my attempts to build rpms for current master, and for earlier
> qt4-based masters, in SL7.1beta failed, (perhaps partly because of sync
> differences between the various repos) I went back to a clean install of
> Fedora 21, and have the current rpmfusion build (0.27.4-3) running on it.
> So I tried to rebuild its src.rpm.  That gets a lot further than before,
> but still fails;  there's a permissions failure when it wants to create
> a ldconfig cache in /etc.  This might be because I'm not using mock, and
> I haven't yet tried to fix it.
> But my main, perhaps sensitive, comment is this:  Usually I have used
> rpmbuild in a terminal window; its verbose logging stream tends to swamp
> any useful info.  This time I used 'rpmbuild --rebuild --quiet' which
> restricts itself to reporting warnings and errors - and the (incomplete)
> log size is 20.9 KiB.
> Many, but not all, of the warnings are signed/unsigned comparisons.
> Perhaps they are of long standing and known to be unimportant, but I'm a
> bit surprised. I suppose I ought to look at some buildbot logs.
> And I'm not complaining.  Oh well, back to the hunt...
> Here, in case they ring any bells, are the last few lines of the log:
> external/ioapi.c: In function 'ferror_file_func':
> external/ioapi.c:159:11: warning: unused parameter 'opaque'
> [-Wunused-parameter]
>      voidpf opaque;
>             ^
> ldconfig: Can't create temporary cache file /etc/ld.so.cache~:
> Permission denied
> make[2]: [install_setting] Error 1 (ignored)
> make[3]: [install-data] Error 1 (ignored)
> make[3]: [install-data] Error 1 (ignored)
> cpio: mythtv-0.27.4/mythtv/external/qjson/src/json_parser.tab.cc: Cannot
> stat: No such file or directory
> cpio: mythtv-0.27.4/mythtv/external/qjson/src/json_parser.tab.hh: Cannot
> stat: No such file or directory
> 67860 blocks
> warning: File not found by glob:
> /home/john/rpmbuild/BUILDROOT/mythtv-0.27.4-3.fc21.x86_64/usr/lib64/*.a
> [john at localhost SRPMS]$
> John

My apologies - particularly to Richard;  the log only reported warnings, 
ignoring success.  I find I have a full set of newly-built rpms...

Onward and upward!

More information about the mythtv-dev mailing list