[mythtv] Video is choppy where is was not before

Richard Jones mythtv-dev@snowman.net
01 Sep 2002 18:22:48 +1000

On Sun, 2002-09-01 at 11:29, kleeschu@mindspring.com wrote:
> I bought a new motherboard and cpu this week,
> AMD 1900+
> SiS 735 based MB
> I installed all the required software and found that the video was now
> choppy. The picture was clear, but the picture would pause for a second and
> then speed up to catch up after pausing. So I thought it may have something
> to do w/ the hardware. I switched back to the other box running mythtv-0.5,
> the same thing was happening (it was the same software, I installed the old
> Via MB and 1.7 Ghz Celeron back into the computer). So I am thinking the
> hardware is not the problem, just something in my configuration. I tried
> all different resolutions and settings in the settings.txt. I tried using
> the open source "nv" driver. Nothing worked. Here's my config

It sounds like the hard drive may not be keeping up with the job. What
does hdparm -tT /dev/hda (or whatever harddrive you are writing your
video output to), i.e. have you tuned your harddrive with hdparm
(numbers you should see here should be up around 40 MB/sec for the
second number hdparm will give you, numbers MUCH lower than this (say
lower than 20-30 MB/sec depending on harddrive) may mean you are not
running with DMA turned on.  hdparm -d1 -c1 /dev/hda is usually a good
start.  Now, its possible that you know all this stuff and are thinking
"Of course I've tuned my hard drive". I'm not sure what chipset you have
on the  SiS motherboard, but the 2.4.18 had a bug with newest VIA ide
chipsets which did not allow them to make drives go into DMA mode. 
Update to 2.4.19 and try the hdparm stuff and see if your problem

Hope that helps,