[mythtv-users] MythTV not really deleting files

Jan Ceuleers jan.ceuleers at gmail.com
Wed Jan 31 17:44:40 UTC 2024


On 31/01/2024 17:03, Peter Bennett wrote:
>
> On 1/31/24 10:21, Timothy Witham wrote:
>>
>> On 1/31/24 08:31, Peter Bennett wrote:
>>>
>>> On 1/31/24 01:39, Timothy Witham wrote:
>>>> Since I was in perl and not SQL, I opted to do this like
>>>> flush_deleted_recgroup.pl did.  This mostly worked, it caused
>>>> backend to start deleting the files one by one.  But after several
>>>> dozen, he started complaining:
>>>>
>>>> Jan 30 13:27:59 mythtv mythbackend: mythbackend[2980]: E
>>>> DeleteThread mythdbcon.cpp:238 (OpenDatabase) [DBManager870] Unable
>>>> to connect to database!
>>>> Jan 30 13:27:59 mythtv mythbackend: mythbackend[2980]: E
>>>> DeleteThread mythdbcon.cpp:239 (OpenDatabase) Driver error was
>>>> [1/1040]:#012QMYSQL: Unable to connect#012Database error
>>>> was:#012Too many connections
>>>> Jan 30 13:27:59 mythtv mythbackend: mythbackend[2980]: E
>>>> DeleteThread mainserver.cpp:2411 (DoDeleteThread) MainServer: ERROR
>>>> opening database connection for Delete Thread for chanid 1181
>>>> recorded at 2021-01-20T14:30:00Z.  Program will NOT be deleted.
>>>>
>>>> Does this indicate a bug that each delete is a new connection that
>>>> doesn't close?  Or did I do something wrong?  Backend restart got
>>>> the deletes going again.
>>>
>>> What version of MythTV are you running? I remember this bug was
>>> reported years ago and was  fixed. Maybe the bug is back?
>>>
>> mythbackend version: fixes/33
>> [v33.1+fixes.202401260819.512d723c83~ubuntu20.04.1] www.mythtv.org
>>
>> -Tim
>>
>>
>>
> Please report that as a bug in MythTV issues in github.
Surely "too many connections" suggests a MySQL configuration issue
rather than a MythTV bug?


More information about the mythtv-users mailing list