[mythtv-users] Struggling to build v34 on Opensuse leap 15.4 and 15.5

James Linder jam at tigger.ws
Sun Feb 11 13:51:01 UTC 2024



> On Feb 11, 2024, at 21:32, Paul Gardiner <lists at glidos.net> wrote:
> 
> Mythtv now requires gcc8 and Opensuse is still on gcc7. Opensuse has gcc8 packages. I've tried adding BuildRequires lines for those packages in my .spec file and adding --cc=gcc8 --cxx=g++8 to the configure options. I get an error message "gcc8 is unable to create an executable file". I've also tried adding BuildRequrires lines for libgcc_s1-gcc8 and libstdc++6-gcc8, but those conflict with the gcc7 versions. I'm wondering if this is a lost cause, or whether someone knows a trick to get this to work.

Paul I built for leap 15.5 without much addo

First install gcc-13 and g++-13
Next install python 3.11
as per the wiki install ansible

$ ./configure --cc=gcc-13 --cxx=g++-13 --enable-set-cc-default --python=python3.11

install the python devel stuff
$ pip3 install mysqlclient

(can’t recall if I edited and commented the test mysql in configure)
Make normally and sudo make install

James


More information about the mythtv-users mailing list