[mythtv-users] Updated MythTV - now my schedules no longer update. XMLTV woes

Douglas Peale Douglas_Peale at Comcast.net
Sun May 7 05:46:55 UTC 2023

On 5/6/23 22:25, Will Dormann wrote:
> Well, I suppose I celebrated too early in updating MythTV.  After my SchedulesDirect data expired, I now realize that I have 
> no program guide since I did the update.
> Apparently "DataDirect" is no longer a things that's supported, and I now need to use XMLTV.  The problem is, I can't seem to 
> find any guidance that I can understand.
> According to https://www.mythtv.org/wiki/XMLTV , I should be able to just run mythtv-setup and tell MythTV to use XMLTV, and 
> everything should be fine.   When exiting mythtv-setup, and I'm prompted to run mythfilldatabase, I see a brief terminal 
> window that shows the usage for how to run mythfilldatabase.  After a bit of hassle, I finally realized that I had a 
> "--remove-new-channels" option set in my MythFillDatabaseArgs in the settings table. After removing this, the error went away.
> However, there's still nothing in my schedules.  There is no configuration file in $HOME/.xmltv.
> So I figure I'd try the command line setup as outlined at https://www.mythtv.org/wiki/XMLTV
> I ran:
> /usr/bin/tv_grab_zz_sdjson --configure --config-file $HOME/.mythtv/FiOS.xmltv
> only to be asked to select what sort of cable lineup I have in my zipcode.   Which is somewhat surprising to me, given that 
> I've already configured exactly how my channel lineup is in SchedulesDirect directly.
> Elsewhere in this list I saw the advice to run --manage-lineups instead of --configure.  I tried this, and it seems that I 
> could add a generic FiOS lineup, but not the one that I had already configured in SchedulesDirect that matches what I actually 
> subscribe to.
> When I try to edit the channel lineup, I get:
>> Select one: [0,1,2,3,4,5 (default=0)] 5
>> Database has not been initialized (or cannot be opened)
> Nothing I've tried has resulted in any .xmltv file being written. I do have a SchedulesDirect.DB in my ~/.xmltv directory.
> All of this has been quite frustrating.  Does anybody have any guidance on how a normal human being can update from an old 
> (DataDirect SchedulesDirect) configuration to a new one that uses XMLTV?
> Thanks
> -WD
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

One thing that I did not get from the wiki is that you MUST run tv_grab_zz_sdjson as user mythtv with user mythtv's environment.

Running this from within mythbackendsetup does not work since it will save the config files in your local environment.

I found that I was able to do this by running:

sudo runuser -l mythtv

which switches you to a shell as user mythtv in the mythtv environment, then running:

tv_grab_zz_sdjson --configure --config-file $HOME/.mythtv/North.xmltv


where you replace the word "North" with whatever name you called your "video source" when you set it up.

Look in /var/log/mythtv/mythfilldatabase.log for clues about whatever else is going on.

everything else in https://www.mythtv.org/wiki/XMLTV made enough sense to me for me to get it working.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x7B9B5178E6AE112A.asc
Type: application/pgp-keys
Size: 2452 bytes
Desc: OpenPGP public key
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20230506/3e3417e4/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 203 bytes
Desc: OpenPGP digital signature
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20230506/3e3417e4/attachment.sig>

More information about the mythtv-users mailing list